Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 623462 - Gtkterm clipboard copy/paste
Gtkterm clipboard copy/paste
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gtkterm (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Dan Horák
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-11 16:18 EDT by Zach Davis
Modified: 2010-11-13 09:20 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-13 09:20:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch file for Gtkterm source code - adds clipboard copy/paste (1.93 KB, text/plain)
2010-08-11 16:18 EDT, Zach Davis
no flags Details

  None (edit)
Description Zach Davis 2010-08-11 16:18:50 EDT
Created attachment 438289 [details]
Patch file for Gtkterm source code - adds clipboard copy/paste

Gtkterm currently has the ability to record to and from files, but no ability to copy and paste to the clipboard.  I have included a patch that adds an 'Edit' menu that contains 'Copy', 'Paste', and 'Copy All'.  These commands copy text to and from the vte window to the clipboard.
Comment 1 Dan Horák 2010-08-11 16:44:35 EDT
gtkterm already has the capability to copy and paste to the clipboard, but it's well hidden -
copy: ctrl-insert
paste: shift-insert
IMHO it's coming from the vte library that's used for the terminal interface.

Thanks for the patch that brings more standard shortcuts and I expect to integrate it during the next few days.
Comment 2 Zach Davis 2010-08-11 17:30:21 EDT
@Dan: You are correct about the C-insert and shift-insert - they are coming from the vte widget, but it isn't very handy and not at all documented within the application (that I could find, anyway).
Comment 3 Dan Horák 2010-08-12 03:54:35 EDT
I think there is a room to reopen the development of gtkterm. Or to create a fork ...
Comment 4 Hans de Goede 2010-08-12 04:39:03 EDT
Hi,

(In reply to comment #3)
> I think there is a room to reopen the development of gtkterm. Or to create a
> fork ...    

After seeing the 2 patches from Zach I was thinking about the same lines. Zach would you be interested in starting a new upstream project for gtkterm ?
Comment 5 Zach Davis 2010-08-12 10:51:51 EDT
Sure! I have a couple more ideas for gtkterm.  It would be my first foray into fedora development, but I can do the coding.
Comment 6 Hans de Goede 2010-08-12 11:03:33 EDT
(In reply to comment #5)
> Sure! I have a couple more ideas for gtkterm.  It would be my first foray into
> fedora development, but I can do the coding.    

Hi,

When we say upstream we are not talking about Fedora, but about setting up a website and a VCS (say git) in some generic place (sf.net, fedorahosted.org) where the new enhanced gtkterm can be downloaded by other distros too. Preferably doing regular tarbal releases so that distro's don't need to depend on packaginv git snapshots.

A good starting place would be mailing the current gtkterm sf.net project maintainers and asking them if they are ok with you picking it up and if they can make you an admin at sf.net. Then you can use sf.net to create a git repo, and to upload tarbals too.

Regards,

Hans
Comment 7 Dan Horák 2010-08-12 11:22:03 EDT
but we package gtkterm from http://www.jls-info.com/julien/linux/ which is different from the sf.net one (http://sourceforge.net/projects/gtkterm/ and http://gtkterm.feige.net/)
Comment 8 Hans de Goede 2010-08-12 11:35:00 EDT
(In reply to comment #7)
> but we package gtkterm from http://www.jls-info.com/julien/linux/ which is
> different from the sf.net one (http://sourceforge.net/projects/gtkterm/ and
> http://gtkterm.feige.net/)    

Ah rights, oops. Sorry. So taking over the sf.net project is not a good idea. 

Zach,

If you want to do this (become a regular upstream for gtkterm) you will need to find some hosting for it (say fedorahosted.org), but first discuss this with Julien. Maybe Julien is willing to integrate your patches and do a new release and if not hopefully he will put up a link on his gtkterm webpage to the new project page for your continuation of gtkterm.

Regards,

Hans
Comment 9 Dan Horák 2010-08-12 12:53:52 EDT
If I remember correctly I tried to contact Julien few years ago, but didn't get any response. Sending him a mail about your intentions should be the first step anyway. After a positive response or after some time without response I would open a project on e.g. fedorahosted.
Comment 10 Zach Davis 2010-08-12 18:53:42 EDT
Julien emailed me back this afternoon, and he has agreed on allowing me to take up maintenance of Gtkterm.  I will try to get it up on fedorahosted in the next couple of days.  Initially I plan on just re-hosting Julien's code with the current patches applied, so everybody has time to make the shift before any big code changes are made.  Thanks Hans and Dan for helping work this out.

~Zach
Comment 11 Dan Horák 2010-08-16 04:28:21 EDT
(In reply to comment #10)
> Julien emailed me back this afternoon, and he has agreed on allowing me to take
> up maintenance of Gtkterm.  I will try to get it up on fedorahosted in the next
> couple of days.  Initially I plan on just re-hosting Julien's code with the
> current patches applied, so everybody has time to make the shift before any big
> code changes are made.  Thanks Hans and Dan for helping work this out.

Zach, thanks for the very good news and in this case I will wait with updating the package on the new version, which in my opinion could include all the accumulated patches including these two.
Comment 12 Hans de Goede 2010-09-10 03:22:52 EDT
Zach,

I just checked and I see that you've created a homepage at fedorahosted:
https://fedorahosted.org/gtkterm/

Which is great! I also see you've done a 0.99.6 release. I don't see anything about clipboard copy/paste in the changelog, but the scrollbar changes do see to be there. Should we update to that release or wait a bit ?

Note we need to update soonish, as we need to fix bug 631235 (or we could fix that bug using the current version, seems to be a missing buildrequires).

Regards,

Hans
Comment 13 Zach Davis 2010-09-12 12:49:58 EDT
Hans-

I have just fixed and tested this bug in F14 rawhide. It is fixed in the 0.99.6 release.  I defiantly recommend using this release over the 0.99.5 one.  The only ways that it differs is the patches are applied, version info and contact info is updated, and build bug for F14 is fixed.

~Zach
Comment 14 Hans de Goede 2010-11-13 09:20:51 EST
Zach, thanks for the patches and your work as new upstream maintainer!

This is fixed in gtkterm-0.99.6-1.fc15, closing.

Note You need to log in before you can comment on or make changes to this bug.