Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 623491 - Vala in Fedora <= 14 is out to date
Vala in Fedora <= 14 is out to date
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: vala (Show other bugs)
14
All Linux
low Severity medium
: ---
: ---
Assigned To: Michel Alexandre Salim
Fedora Extras Quality Assurance
:
: 626832 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-11 18:21 EDT by MERCIER Jonathan
Modified: 2010-09-16 04:08 EDT (History)
4 users (show)

See Also:
Fixed In Version: vala-0.9.8-1.fc14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-09-15 23:50:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description MERCIER Jonathan 2010-08-11 18:21:54 EDT
hello i need a relase up to date for valide.
vala 0.9.5 is out can you update and push to stable thanks (at least F13 - F14)

Thanks
Comment 1 Michel Alexandre Salim 2010-08-12 04:35:40 EDT
This will require rebuilding the entire Vala stack, since the sonames have changed. Peter, what do you think?

I'll rebuild Vala and ask it to be tagged override, and then after the entire stack is rebuild we can push the entire sets of updates to -testing.
Comment 2 MERCIER Jonathan 2010-08-12 09:19:56 EDT
thanks
Comment 3 Peter Robinson 2010-08-12 10:37:24 EDT
(In reply to comment #1)
> This will require rebuilding the entire Vala stack, since the sonames have
> changed. Peter, what do you think?

I have no issues assuming its just an ABI change and not a API change. I'm happy for anyone to rebuild my packages as at the moment my time is very limited, or if someone can give me a list of mine that need the rebuild.
Comment 4 Peter Robinson 2010-08-14 12:33:51 EDT
Michel can you let me know when you've got 0.9.5 built and tagged into the build overrides.

Doing a 'repoquery --whatrequires vala' it looks like the following will need to be rebuilt:
anjuta
eekboard-devel
ethos-vala
gedit-vala
gstreamer-rtsp-vala
gupnp-vala
libatasmart-devel
libgee-devel
libgexiv2-devel
pulseaudio-libs-devel
valide
Comment 5 MERCIER Jonathan 2010-08-18 07:42:12 EDT
a build override will be good
Comment 6 MERCIER Jonathan 2010-08-26 03:04:20 EDT
ping
Comment 7 MERCIER Jonathan 2010-08-27 06:10:07 EDT
*** Bug 626832 has been marked as a duplicate of this bug. ***
Comment 8 Peter Robinson 2010-08-30 10:24:10 EDT
Looking at this further I think the only things that will need to be rebuilt are the packages that depend on libvala.so.0 as the rest are just bindings that have vala as a build time dependency not a run time dependency (given that vala is used to generate C code)

$ repoquery --whatrequires libvala.so.0
anjuta-1:2.30.0.0-2.fc14.i686
vala-devel-0:0.9.4-1.fc14.i686
valide-0:0.6.1-0.22.20103003svn511.fc14.i686

$ repoquery --whatrequires vala
vala-0:0.9.4-1.fc14.i686
vala-0:0.9.4-1.fc14.x86_64
anjuta-1:2.30.0.0-2.fc14.i686
anjuta-1:2.30.0.0-2.fc14.x86_64
eekboard-devel-0:0.0.4-2.fc14.i686
eekboard-devel-0:0.0.4-2.fc14.x86_64
eekboard-devel-0:0.0.5-1.fc14.i686
eekboard-devel-0:0.0.5-1.fc14.x86_64
ethos-vala-0:0.2.2-7.fc14.noarch
gedit-vala-0:0.6.1-1.fc13.x86_64
gstreamer-rtsp-vala-0:0.10.5-2.fc14.x86_64
gupnp-vala-0:0.6.9-1.fc14.x86_64
libatasmart-devel-0:0.17-2.fc13.i686
libatasmart-devel-0:0.17-2.fc13.x86_64
libgee-devel-0:0.5.1-1.fc14.i686
libgee-devel-0:0.5.1-1.fc14.x86_64
libgexiv2-devel-0:0.1.0-1.fc14.i686
libgexiv2-devel-0:0.1.0-1.fc14.x86_64
libgexiv2-devel-0:0.2.0-1.fc14.i686
libgexiv2-devel-0:0.2.0-1.fc14.x86_64
pulseaudio-libs-devel-0:0.9.21-6.fc13.i686
pulseaudio-libs-devel-0:0.9.21-6.fc13.x86_64
telepathy-glib-vala-0:0.11.13-1.fc14.x86_64
telepathy-glib-vala-0:0.11.14-1.fc14.x86_64
vala-devel-0:0.9.4-1.fc14.i686
vala-devel-0:0.9.4-1.fc14.x86_64
vala-doc-0:0.9.4-1.fc14.x86_64
vala-tools-0:0.9.4-1.fc14.x86_64
valide-0:0.6.1-0.22.20103003svn511.fc14.i686
valide-0:0.6.1-0.22.20103003svn511.fc14.x86_64

Given that I'll requested a build override for (currently) F-14 so we can get folks and what ever else in that needs the later version of vala. Ticket is:

https://fedorahosted.org/rel-eng/ticket/4042

Once the override is in please rebuild ajunta / valide and what ever else you think should be built and put the package build details in this ticket and I'll submit them all together as one update so we don't have broken deps.
Comment 9 MERCIER Jonathan 2010-08-30 16:42:43 EDT
for me i need use a new version of valdie beacause now valide works with 0.9.5 and not for under version, tell me when i can update valide is broken since 2 weeks, thanks
Comment 10 Adam Tkac 2010-09-01 09:22:50 EDT
(In reply to comment #9)
> for me i need use a new version of valdie beacause now valide works with 0.9.5
> and not for under version, tell me when i can update valide is broken since 2
> weeks, thanks

vala 0.9.7 is already in the F14 build root:

$ koji latest-pkg dist-f14-build vala
Build                                     Tag                   Built by
----------------------------------------  --------------------  ----------------
vala-0.9.7-1.fc14                         dist-f14-override     bpepple

So you can go ahead and rebuild valide in Fedora 14 and master branches.
Comment 11 Brian Pepple 2010-09-03 11:08:14 EDT
(In reply to comment #10)
> (In reply to comment #9)
> > for me i need use a new version of valdie beacause now valide works with 0.9.5
> > and not for under version, tell me when i can update valide is broken since 2
> > weeks, thanks
> 
> vala 0.9.7 is already in the F14 build root:
> 
> $ koji latest-pkg dist-f14-build vala
> Build                                     Tag                   Built by
> ----------------------------------------  -------------------- 
> ----------------
> vala-0.9.7-1.fc14                         dist-f14-override     bpepple
> 
> So you can go ahead and rebuild valide in Fedora 14 and master branches.

When Valide is rebuilt, please ping me so that we can push this all (vala, gedit-vala, valide) out in push in Bodhi. Thanks!
Comment 12 MERCIER Jonathan 2010-09-03 11:20:42 EDT
ok i have a problem with upstream i do some works for try fix it ... (erf)
thanks
Comment 13 MERCIER Jonathan 2010-09-03 17:21:45 EDT
they are vala-devel 0.9.7?
Comment 14 Brian Pepple 2010-09-03 18:40:17 EDT
(In reply to comment #13)
> they are vala-devel 0.9.7?

Yes.
Comment 15 MERCIER Jonathan 2010-09-08 13:56:18 EDT
is done for me
Comment 16 Brian Pepple 2010-09-08 14:06:25 EDT
(In reply to comment #15)
> is done for me

Has an f14 build been done for Valide? If so, we need to submit vala, gedit-vala, and valide all in the same update in bodhi.
Comment 18 Brian Pepple 2010-09-08 14:27:21 EDT
(In reply to comment #17)
> yes valide is build for f14:
> https://admin.fedoraproject.org/updates/valide-0.7.0-5.20100904svn689.fc14?_csrf_token=541fb8457070683344dc994ffd9590aea060bd6b

We need to add the vala & gedit-vala builds to that update, so they all get pushed together.  Please add them since I can't edit that update in bodhi.
Comment 19 Brian Pepple 2010-09-08 14:28:20 EDT
(In reply to comment #18)
> (In reply to comment #17)
> > yes valide is build for f14:
> > https://admin.fedoraproject.org/updates/valide-0.7.0-5.20100904svn689.fc14?_csrf_token=541fb8457070683344dc994ffd9590aea060bd6b
> 
> We need to add the vala & gedit-vala builds to that update, so they all get
> pushed together.  Please add them since I can't edit that update in bodhi.

Oh, and also add this bug # to the update so this bug is closed when it's pushed to stable. thanks!
Comment 20 Brian Pepple 2010-09-11 15:49:59 EDT
(In reply to comment #17)
> yes valide is build for f14:
> https://admin.fedoraproject.org/updates/valide-0.7.0-5.20100904svn689.fc14?_csrf_token=541fb8457070683344dc994ffd9590aea060bd6b

Ping. This update needs to be fixed asap to include vala & gedit-vala. This update is holding up building Empathy for F14.
Comment 21 Fedora Update System 2010-09-12 19:11:11 EDT
valide-0.7.0-5.20100904svn689.fc14,vala-0.9.7-1.fc14,gedit-vala-0.9.3-1.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/valide-0.7.0-5.20100904svn689.fc14,vala-0.9.7-1.fc14,gedit-vala-0.9.3-1.fc14
Comment 22 Fedora Update System 2010-09-14 12:08:53 EDT
vala-0.9.8-1.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/vala-0.9.8-1.fc13
Comment 23 Fedora Update System 2010-09-15 01:42:26 EDT
vala-0.9.8-1.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update vala'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/vala-0.9.8-1.fc13
Comment 24 Fedora Update System 2010-09-15 09:33:38 EDT
gedit-vala-0.9.3-1.fc14,vala-0.9.8-1.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/gedit-vala-0.9.3-1.fc14,vala-0.9.8-1.fc14
Comment 25 Michel Alexandre Salim 2010-09-15 12:16:27 EDT
Note: Fedora 13 will not be updated due to the package renaming introduced in Vala 0.9.5; rebuilding a lot of packages is rather destabilizing.
Comment 26 Peter Robinson 2010-09-15 18:03:37 EDT
(In reply to comment #25)
> Note: Fedora 13 will not be updated due to the package renaming introduced in
> Vala 0.9.5; rebuilding a lot of packages is rather destabilizing.

I presume you mean the soname bump. Most packages use it for source generation and there's only gedit-vala and valide that actually links against the library.
Comment 27 Fedora Update System 2010-09-15 23:50:05 EDT
vala-0.9.8-1.fc14, gedit-vala-0.9.3-1.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 28 Michel Alexandre Salim 2010-09-16 04:08:23 EDT
(In reply to comment #26)
> (In reply to comment #25)
> > Note: Fedora 13 will not be updated due to the package renaming introduced in
> > Vala 0.9.5; rebuilding a lot of packages is rather destabilizing.
> 
> I presume you mean the soname bump. Most packages use it for source generation
> and there's only gedit-vala and valide that actually links against the library.

And anjuta as well, which is why I feel uncomfortable rebuilding the F-13 stack. Plus the consensus seems to be moving against disruptive updates in existing releases anyway.

Note You need to log in before you can comment on or make changes to this bug.