Bug 623527 - fence_vmware can not connect to fence device
Summary: fence_vmware can not connect to fence device
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: cman (Show other bugs)
(Show other bugs)
Version: 5.4
Hardware: All Linux
low
medium
Target Milestone: rc
: ---
Assignee: Christine Caulfield
QA Contact: Cluster QE
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-08-12 03:34 UTC by Yang Ren
Modified: 2016-04-26 15:47 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-13 16:30:33 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Yang Ren 2010-08-12 03:34:08 UTC
It's a problem about old fence_vmware. I'm try to fence a vmware virtual machine in a rhel 5.4 box.

VMware information
VMware ESX Server 3i 3.5.0 build-142291
ip: 10.66.72.61
root/123qweP

guest information
10.66.72.47
root/redhat

#fence_vmware -a 10.66.72.61 -l root -p 123qweP -L root -P redhat -o status -n /vmfs/volumes/e03bc715-5155bb63/virtlab-test-1/virtlab-test-1.vmx
Unable to connect/login to fencing device

But I can ssh to that host
[root@virtlab-stage ~]# nmap 10.66.72.61

Starting Nmap 4.11 ( http://www.insecure.org/nmap/ ) at 2010-08-12 11:32 CST
Interesting ports on 10.66.72.61:
Not shown: 1675 closed ports
PORT    STATE SERVICE
22/tcp  open  ssh
80/tcp  open  http
427/tcp open  svrloc
443/tcp open  https
902/tcp open  iss-realsecure-sensor

Nmap finished: 1 IP address (1 host up) scanned in 0.843 seconds

I'm using cman-2.0.115-1.el5

Comment 1 Perry Myers 2010-08-12 14:36:02 UTC
fence_vmware in RHEL5.4 was TechnicalPreview and was completely replaced by a rewritten agent in RHEL5.5.  So if you can reproduce this issue with the RHEL5.5 version of fence_vmware, please let us know.  Otherwise this will be closed as CURRENTRELEASE since we will not be doing z-streams for the 5.4 version of fence_vmware.

General note: fence_vmware in RHEL5.5 is also still TechPreview

Comment 2 Yang Ren 2010-08-13 01:07:17 UTC
(In reply to comment #1)
> fence_vmware in RHEL5.4 was TechnicalPreview and was completely replaced by a
> rewritten agent in RHEL5.5.  So if you can reproduce this issue with the
> RHEL5.5 version of fence_vmware, please let us know.  Otherwise this will be
> closed as CURRENTRELEASE since we will not be doing z-streams for the 5.4
> version of fence_vmware.
> 
> General note: fence_vmware in RHEL5.5 is also still TechPreview    

Thanks, I successed with fence_agents 3.0+ version. Properly we need upgrade our production server to rhel 5.5. Just close it.

Comment 3 Perry Myers 2010-08-13 16:30:33 UTC
Ok thanks, closing based on comment #2


Note You need to log in before you can comment on or make changes to this bug.