Bug 623534 - SELinux empêche l'accès en "read" à /var/lib/boinc/projects/www.worldcommunitygrid.org/wcg_hfcc_autodock_6.11_i686-pc-linux-gnu on fifo_fi
SELinux empêche l'accès en "read" à /var/lib/boinc/projects/www.worldcommunit...
Status: CLOSED DUPLICATE of bug 623533
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
13
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Fedora Extras Quality Assurance
setroubleshoot_trace_hash:fdd85d05f68...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-12 00:15 EDT by Nicolas Berrehouc
Modified: 2010-08-12 04:18 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-12 04:18:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nicolas Berrehouc 2010-08-12 00:15:11 EDT
Résumé:

SELinux empêche l'accès en "read" à
/var/lib/boinc/projects/www.worldcommunitygrid.org/wcg_hfcc_autodock_6.11_i686-pc-linux-gnu
on fifo_fi

Description détaillée:

[wcg_faah_autodo a un type permissif (boinc_project_t). Cet accès n'a pas été
refusé.]

SELinux a refusé l'accès demandé par wcg_hfcc_autodo. Il n'est pas prévu que
cet accès soit requis par wcg_hfcc_autodo et cet accès peut signaler une
tentative d'intrusion. Il est également possible que cette version ou cette
configuration spécifique de l'application provoque cette demande d'accès
supplémenta

Autoriser l'accès:

Vous pouvez créer un module de stratégie locale pour autoriser cet accès -
lisez la FAQ (http://docs.fedoraproject.org/selinux-faq-fc5/#id2961385) Merci de
remplir un rapport de bogue.

Informations complémentaires:

Contexte source               system_u:system_r:boinc_project_t:s0
Contexte cible                system_u:system_r:boinc_project_t:s0
Objets du contexte            fifo_file [ fifo_file ]
source                        wcg_faah_autodo
Chemin de la source           /var/lib/boinc/projects/www.worldcommunitygrid.org
                              /wcg_faah_autodock_6.07_i686-pc-linux-gnu
Port                          <Inconnu>
Hôte                         (supprimé)
Paquetages RPM source         
Paquetages RPM cible          
Politique RPM                 selinux-policy-3.7.19-44.fc13
Selinux activé               True
Type de politique             targeted
Mode strict                   Enforcing
Nom du plugin                 catchall
Nom de l'hôte                (supprimé)
Plateforme                    Linux (supprimé) 2.6.33.6-147.2.4.fc13.i686.PAE #1
                              SMP Fri Jul 23 17:21:06 UTC 2010 i686 i686
Compteur d'alertes            31
Première alerte              mer. 11 août 2010 06:36:09 CEST
Dernière alerte              jeu. 12 août 2010 06:09:53 CEST
ID local                      62c337c0-553a-4c1e-ae33-370045505045
Numéros des lignes           

Messages d'audit bruts        

node=(supprimé) type=AVC msg=audit(1281586193.942:131): avc:  denied  { read } for  pid=2782 comm="wcg_hfcc_autodo" path="pipe:[29429]" dev=pipefs ino=29429 scontext=system_u:system_r:boinc_project_t:s0 tcontext=system_u:system_r:boinc_project_t:s0 tclass=fifo_file

node=(supprimé) type=SYSCALL msg=audit(1281586193.942:131): arch=40000003 syscall=3 success=yes exit=148 a0=7 a1=c7be1d0 a2=94 a3=81c6220 items=0 ppid=2767 pid=2782 auid=4294967295 uid=492 gid=480 euid=492 suid=492 fsuid=492 egid=480 sgid=480 fsgid=480 tty=(none) ses=4294967295 comm="wcg_hfcc_autodo" exe="/var/lib/boinc/projects/www.worldcommunitygrid.org/wcg_hfcc_autodock_6.11_i686-pc-linux-gnu" subj=system_u:system_r:boinc_project_t:s0 key=(null)



Hash String generated from  catchall,wcg_faah_autodo,boinc_project_t,boinc_project_t,fifo_file,read
audit2allow suggests:

#============= boinc_project_t ==============
allow boinc_project_t self:fifo_file read;
Comment 1 Nicolas Berrehouc 2010-08-12 00:26:04 EDT
Boinc_client seems to work fine but SELinux always show this message.
/var/log/messages contains a lot of alert like.

Aug 12 06:09:20 Hostname setroubleshoot: SELinux empêche l'accès en "read" à /var/lib/boinc/projects/www.worldcommunitygrid.org/wcg_hfcc_autodock_6.11_i686-pc-linux-gnu on fifo_file. For complete SELinux messages. run sealert -l 62c337c0-553a-4c1e-ae33-370045505045
Aug 12 06:10:08 Hostname setroubleshoot: [dbus.proxies.ERROR] Introspect error on :1.65:/org/fedoraproject/Setroubleshootd: dbus.exceptions.DBusException: org.freedesktop.DBus.Error.NoReply: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.
Aug 12 06:10:15 Hostname setroubleshoot: SELinux empêche l'accès en "write" à /var/lib/boinc/projects/www.worldcommunitygrid.org/wcg_hfcc_autodock_6.11_i686-pc-linux-gnu on fifo_file. For complete SELinux messages. run sealert -l 13a7b866-b604-42bc-baed-d4f416250031
Aug 12 06:10:16 Hostname setroubleshoot: SELinux empêche l'accès en "read" à /var/lib/boinc/projects/www.worldcommunitygrid.org/wcg_hfcc_autodock_6.11_i686-pc-linux-gnu on fifo_file. For complete SELinux messages. run sealert -l 62c337c0-553a-4c1e-ae33-370045505045

Before the last update all was working fine without Setroubleshoot message.
Comment 2 Miroslav Grepl 2010-08-12 04:18:55 EDT

*** This bug has been marked as a duplicate of bug 623533 ***

Note You need to log in before you can comment on or make changes to this bug.