Bug 623567 - man-page/--help inconsistency
Summary: man-page/--help inconsistency
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: fcoe-utils (Show other bugs)
(Show other bugs)
Version: 6.0
Hardware: All Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Petr Šabata
QA Contact: Miroslav Vadkerti
URL: http://open-fcoe.org/openfc/bugzilla/...
Whiteboard:
Keywords: ManPageChange, Patch
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-08-12 07:42 UTC by Miroslav Vadkerti
Modified: 2011-05-19 14:20 UTC (History)
3 users (show)

Fixed In Version: fcoe-utils-1.0.14-14.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-05-19 14:20:13 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
fcnsq usage patch (467 bytes, patch)
2010-10-12 13:26 UTC, Petr Šabata
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:0743 normal SHIPPED_LIVE fcoe-utils bug fix update 2011-05-18 18:09:08 UTC

Description Miroslav Vadkerti 2010-08-12 07:42:23 UTC
Description of problem:
I found come inconsistency issues with help vs man-page options in some fcoe-utils bins:


2 option(s) reported by the fcoeadm --help ONLY (not in man-page):
	--Scan
	-S

1 option(s) reported for fcnsq by the man page ONLY (not in --help):
	-q
(short option not mentioned in help)

Version-Release number of selected component (if applicable):
fcoe-utils-1.0.14-8.el6

How reproducible:
100%

Steps to Reproduce:
1. man fcoeadm; fcoeadm --help
3. man fcnsq; fcnsq --help
  
Actual results:
Inconsistency

Expected results:
Man page and --help consistent

Additional info:

Comment 1 Petr Šabata 2010-10-12 13:26:23 UTC
Created attachment 452964 [details]
fcnsq usage patch

Patch for the fcnsq usage (help) to show the short option for --quiet as well.

Comment 2 Petr Šabata 2010-11-18 13:43:32 UTC
fcnsq fixed in CVS, fcoe-utils-1.0.14-10.el6

Comment 3 Miroslav Vadkerti 2011-01-21 06:29:41 UTC
Petr, what about the -S/--Scan option. This is still not documented in the man page. I assume this is still not available from upstream. But I think we could come up with a documentation string.

Comment 4 Miroslav Vadkerti 2011-01-24 14:32:22 UTC
Thanks to jzeleny for investigation. The -S option does this:
Validates that the interface name has an active fcoe session

Also --Scan option does not work. Please update the options struct to have this working. Thanks!

Comment 5 Petr Šabata 2011-01-24 14:57:40 UTC
Fixed in CVS tag fcoe-utils-1.0.14-13.el6

Comment 6 Petr Pisar 2011-01-24 15:42:20 UTC
doc/fcoeadm.8:
 -S, --Scan ethX
           Validates that the interface name has an active fcoe session.
                                                           ^^^^
The `fcoe' string should be written as `FCoE' as is done at other places of the manual.

Comment 7 Petr Šabata 2011-01-25 15:00:57 UTC
Good point, Petr.
I updated the patch in fcoe-utils-1.0.14-14.el6

Comment 11 errata-xmlrpc 2011-05-19 14:20:13 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-0743.html


Note You need to log in before you can comment on or make changes to this bug.