Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 623577 - [fix available] Ooo.org do not register scripting providers
[fix available] Ooo.org do not register scripting providers
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: openoffice.org (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: David Tardon
desktop-bugs@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-12 04:31 EDT by Tomas Pelka
Modified: 2011-09-13 07:05 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-09-13 07:05:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
manifest for BeanShell (397 bytes, text/xml)
2010-08-12 06:21 EDT, David Tardon
no flags Details
manifest for JavaScript (398 bytes, text/xml)
2010-08-12 06:21 EDT, David Tardon
no flags Details
manifest for Python (384 bytes, text/xml)
2010-08-12 06:21 EDT, David Tardon
no flags Details
create manifests for the extensions during install (3.77 KB, patch)
2010-08-12 09:30 EDT, David Tardon
no flags Details | Diff
manifest.xml template (375 bytes, text/xml)
2010-08-12 09:30 EDT, David Tardon
no flags Details

  None (edit)
Description Tomas Pelka 2010-08-12 04:31:48 EDT
Description of problem:
Ooo.org do not register any scripting providers (Python, JavaScript and BeanShell). To make this stuff working we need to:
1) make an manifest file
2) register provider manually  
# unopkg add --shared --link /usr/share/openoffice.org/extensions/ScriptProviderForPython.zip

David could you please provide more info if needed, thanks.


Version-Release number of selected component (if applicable):
openoffice.org-langpack-ar-3.2.1-19.6.el6

How reproducible:
100%

Steps to Reproduce:
1. Install openoffice.org-pyuno/openoffice.org-rhino/openoffice.org-bsh.
2. Open some file with macros.
3. Open Tools->Macros->Oganize Macros


Actual results:
You can see only "OpenOffice.org Basic".

Expected results:
Except "OpenOffice.org Basic" you should see also "Python", "JavaScript" and "BeanShell".

Additional info:
Comment 3 RHEL Product and Program Management 2010-08-12 04:58:30 EDT
This issue has been proposed when we are only considering blocker
issues in the current Red Hat Enterprise Linux release.

** If you would still like this issue considered for the current
release, ask your support representative to file as a blocker on
your behalf. Otherwise ask that it be considered for the next
Red Hat Enterprise Linux release. **
Comment 4 David Tardon 2010-08-12 06:20:05 EDT
This is caused by a change in 3.2.1, where directories without a manifest are no longer recognized as extensions, so after installation of a package containing one of the providers its registration in %post fails. The providers can be registered manually as follows (example for JavaScript):

1. get the manifest.xml for JavaScript
2. mkdir /usr/share/openoffice.org/extensions/ScriptProviderForJavaScript.zip/META-INF
3. cp manifest.xml /usr/share/openoffice.org/extensions/ScriptProviderForJavaScript.zip/META-INF
4. unopkg add --shared --link --force /usr/share/openoffice.org/extensions/ScriptProviderForJavaScript.zip
Comment 5 David Tardon 2010-08-12 06:21:01 EDT
Created attachment 438390 [details]
manifest for BeanShell
Comment 6 David Tardon 2010-08-12 06:21:24 EDT
Created attachment 438391 [details]
manifest for JavaScript
Comment 7 David Tardon 2010-08-12 06:21:48 EDT
Created attachment 438392 [details]
manifest for Python
Comment 8 David Tardon 2010-08-12 09:30:06 EDT
Created attachment 438438 [details]
create manifests for the extensions during install
Comment 9 David Tardon 2010-08-12 09:30:44 EDT
Created attachment 438440 [details]
manifest.xml template
Comment 11 RHEL Product and Program Management 2011-01-07 10:33:49 EST
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.
Comment 13 RHEL Product and Program Management 2011-07-05 19:47:31 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.
Comment 14 David Tardon 2011-09-13 06:54:37 EDT
We can fix this, but it has been rejected by PM too many times already, hence
we have decided not to propose it again.
Comment 15 RHEL Product and Program Management 2011-09-13 07:05:19 EDT
Development Management has reviewed and declined this request.  You may appeal
this decision by reopening this request.

Note You need to log in before you can comment on or make changes to this bug.