Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 623596 - typing break does not count screen lock time
typing break does not count screen lock time
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: control-center (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Control Center Maintainer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-12 05:21 EDT by Jan "Yenya" Kasprzak
Modified: 2010-10-06 16:44 EDT (History)
2 users (show)

See Also:
Fixed In Version: xorg-x11-server-1.9.0-13.fc14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-10-06 16:44:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan "Yenya" Kasprzak 2010-08-12 05:21:55 EDT
Description of problem:
When the screen is locked by e.g. gnome-screensaver, typing break stops its clock and does not count the time as idle. After unlocking the screen, time to the break remains the same as before locking, despite the keyboard being idle for a long time.

Version-Release number of selected component (if applicable):
control-center-2.30.1-2.fc13.x86_64

How reproducible:
100 %

Steps to Reproduce:
1. Set up a typing break (GNOME foot -> System -> Preferences -> Keyboard -> Typing break)
2. use the computer until the typing break is near (the notification area applet is red blinking)
3. lock the display (GNOME foot -> Lock Screen)
4. wait for 10 minutes
5. unlock the display and use the computer
  
Actual results:
typing break kicks in almost immediately

Expected results:
the timer for the typing break should be reset because the session has been idle for a sufficient time

Additional info:
Probably related bug reports are:

Typing break does not count suspend time
https://bugzilla.gnome.org/show_bug.cgi?id=430797
https://bugzilla.redhat.com/show_bug.cgi?id=485588

gnome-typing-monitor locks only one head
https://bugzilla.gnome.org/show_bug.cgi?id=492974
https://bugzilla.redhat.com/show_bug.cgi?id=448077
Comment 1 Fedora Update System 2010-10-04 13:45:48 EDT
xorg-x11-server-1.9.0-12.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/xorg-x11-server-1.9.0-12.fc14
Comment 2 Fedora Update System 2010-10-05 01:19:37 EDT
xorg-x11-server-1.9.0-12.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update xorg-x11-server'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/xorg-x11-server-1.9.0-12.fc14
Comment 3 Fedora Update System 2010-10-05 13:42:10 EDT
xorg-x11-server-1.9.0-13.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/xorg-x11-server-1.9.0-13.fc14
Comment 4 Fedora Update System 2010-10-06 16:43:58 EDT
xorg-x11-server-1.9.0-13.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.