Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 623597 - grub might have a 1 Terabyte limit
grub might have a 1 Terabyte limit
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: grub (Show other bugs)
14
All Linux
low Severity medium
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-12 05:23 EDT by Thorsten Leemhuis
Modified: 2011-09-07 09:54 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-09-07 09:54:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thorsten Leemhuis 2010-08-12 05:23:18 EDT
Description of problem:
We tried to install a F13 to a partition at the end of a disk with 1,5 TByte but it seems ananconda failed to set up grub properly during install. Trying to do it manually using a F13 Live resulted in this error message when running "root (hd0,6)" in grub:

Selected cylinder exceeds maximum supported by BIOS

We repartitioned and created a root/boot partition completely below 1 TByte and everything worked as expected. Windows 7 and Grub2 from Ubuntu 10.04 work correctly when their partition is at the end of the disk.
Comment 1 Thorsten Leemhuis 2010-08-19 08:55:36 EDT
Tried it with Fedora-14-Alpha-x86_64-Live.iso and hit the same problem

BTW, the complete message that grub displays in both cases was:
Error 18: Selected cylinder exceeds maximum supported by BIOS
I forgot the "error 18" in the initial report, sorry for that
Comment 2 Jon Masters 2010-08-20 14:58:17 EDT
This is likely a BIOS problem. There were several recent upstream discussions, and Tejun wrote an excellent writeup on the ata kernel wiki a while back, too.

Jon.
Comment 3 Thorsten Leemhuis 2010-08-20 15:14:38 EDT
(In reply to comment #2)
> This is likely a BIOS problem.

Then why do Windows and Ubuntu 10.04 (with grub2) work just fine?

> There were several recent upstream discussions,
> and Tejun wrote an excellent writeup on the ata kernel wiki a while back, too.

He wrote a lot about the 4k disks and the 2 (not 1) TByte limit with standard 512-Byte-sector-size-disks due to 32-bit limitation in the MBR afaics.  Or am I missing something here?
Comment 4 Steve Simpson 2011-09-07 09:48:28 EDT
This is a real problem. I am not sure where the limit lies 1-2 TB, but the issue is with grub (0.97). 

I have a Dell r710 with 6 1TB drives. I had them setup as one big space with Raid 6 (about 3.9 TB). RHEL 6.1 would install just fine (in UEFI). 
With the following partitions created from the RedHat installer:
/dev/sda1   /boot/efi 200M
/dev/sda2   /boot       500M
/dev/sda3   /              100G
/dev/sda4   LV            remainder

I also tried the default Red Hat schema, which put the root in the LV as well. 
Both of these failed.

When it rebooted it would stop at the "grub>" prompt. When I tried to manually enter grub commands I got the error:
Error 18: Selected cylinder exceeds maximum supported by BIOS

I finally had to switch to 2 separate Raid Layouts:
  1 TB Raid 1 for system
  3 TB Raid 5 for data

This worked fine, but limited the use of my space and lost my 2 disk redundancy of Raid 6.
Comment 5 Thorsten Leemhuis 2011-09-07 09:54:47 EDT
Steve (and pjones!), feel free to reopen, but I guess this bug is not worth any further investigation from the Fedora perspective(¹), as F16 will mostly use grub2 and a fix for F14 and F15 is unlikely to happen afaics, so I think it's best to close it as "Wontfix".

(¹)might be of interest for RHEL6 OTOH

Note You need to log in before you can comment on or make changes to this bug.