Bug 623605 - [vdsm] [storage] copyimage (create template) failed on error while converting raw: No space left on device
[vdsm] [storage] copyimage (create template) failed on error while converting...
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: vdsm (Show other bugs)
6.1
All Linux
low Severity medium
: rc
: ---
Assigned To: Igor Lvovsky
Haim
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-12 05:56 EDT by Haim
Modified: 2014-01-12 19:46 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-09-02 10:59:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
vdsm log (1.03 MB, application/x-gzip)
2010-08-12 05:56 EDT, Haim
no flags Details

  None (edit)
Description Haim 2010-08-12 05:56:53 EDT
Created attachment 438387 [details]
vdsm log

Description of problem:

Fail to create template, as vdsm practically tears down the image during qemu-img convert operation, which says: "error while converting raw: No space left on device\']",)',)" 

it happens on most vms (I use vm with 2 disks, 1 cow and 1 raw). 

attached some of the log (and full log is attached as well).

819a1faa-dc0c-4720-91e8-b2da7867544f::INFO::2010-08-12 11:54:18,515::volume::518::irs::Volume: tearing down volume 6c4717af-38c1-47ea-846d-e8ecea1cd633/ba485053-e740-46b3-b62e-02ec5bcdcda0 justme False
819a1faa-dc0c-4720-91e8-b2da7867544f::INFO::2010-08-12 11:54:18,516::vg::697::irs::deactivateLV ba485053-e740-46b3-b62e-02ec5bcdcda0
819a1faa-dc0c-4720-91e8-b2da7867544f::DEBUG::2010-08-12 11:54:18,517::misc::92::irs::'/usr/bin/sudo -n /sbin/lvchange --config " devices { preferred_names = [\\"^/dev/mapper/\\"] write_cache_state=0 filter = [ \\"
a%/dev/mapper/14f504e46494c4500687a6a5649302d7a5031732d53457373%\\", \\"r%.*%\\" ] }  backup {  retain_min = 50  retain_days = 0 } " --available n 6c4717af-38c1-47ea-846d-e8ecea1cd633/ba485053-e740-46b3-b62e-02ec5
bcdcda0' (cwd None)
819a1faa-dc0c-4720-91e8-b2da7867544f::DEBUG::2010-08-12 11:54:18,783::misc::111::irs::SUCCESS: <err> = ''; <rc> = 0
819a1faa-dc0c-4720-91e8-b2da7867544f::ERROR::2010-08-12 11:54:18,784::misc::58::irs::low level Image copy failed: ('General Storage Exception: ("rc: 1, err: [\'qemu-img: /rhev/data-center/6acd4aff-334a-44e1-8370-0
48f1ba9962b/6c4717af-38c1-47ea-846d-e8ecea1cd633/images/1fb2cd3b-ade2-40f2-aa45-867ea16b9fa9/ba485053-e740-46b3-b62e-02ec5bcdcda0: error while converting raw: No space left on device\']",)',)
819a1faa-dc0c-4720-91e8-b2da7867544f::ERROR::2010-08-12 11:54:18,785::misc::59::irs::Traceback (most recent call last):
  File "/usr/share/vdsm/storage/task.py", line 973, in _run
    return fn(*args, **kargs)
  File "/usr/share/vdsm/storage/task.py", line 320, in run
    return self.cmd(*self.argslist, **self.argsdict)
  File "/usr/share/vdsm/storage/spm.py", line 107, in run
    return self.func(*args, **kwargs)
  File "/usr/share/vdsm/storage/spm.py", line 627, in copyImage
    volType, volFormat, preallocate, postZero, force)
  File "/usr/share/vdsm/storage/image.py", line 715, in copy
    raise se.CopyImageError(str(e))
CopyImageError: low level Image copy failed: ('General Storage Exception: ("rc: 1, err: [\'qemu-img: /rhev/data-center/6acd4aff-334a-44e1-8370-048f1ba9962b/6c4717af-38c1-47ea-846d-e8ecea1cd633/images/1fb2cd3b-ade2
-40f2-aa45-867ea16b9fa9/ba485053-e740-46b3-b62e-02ec5bcdcda0: error while converting raw: No space left on device\']",)',)


this happens on my rhel6 server using latest vdsm 4.9 available. 



2.6.32-59.1.el6.x86_64
libvirt-0.8.1-22.el6.x86_64
vdsm-4.9-12.el6.x86_64
device-mapper-multipath-0.4.9-25.el6.x86_64
lvm2-2.02.72-4.el6.x86_64
qemu-kvm-0.12.1.2-2.109.el6.x86_64
Comment 1 Haim 2010-08-12 05:59:01 EDT
repro: 

1) work in iscsi storage 
2) create trample from vm running with 2 disks
Comment 3 Igor Lvovsky 2010-08-17 03:56:56 EDT
Work for me for both COW and RAW disks on my RHEL6.
I need you reproduce it, please.
Comment 5 Haim 2010-08-25 06:40:29 EDT
ignore latest comment - Paikov managed to reproduce and Saggi provided a patch.
Comment 6 Saggi Mizrahi 2010-08-25 06:56:37 EDT
It turns out Igor doesn't think it is the same bug. I tend to trust him on that.
Haim, please reproduce on old build so we can be sure it is fixed in new one.
Comment 9 Igor Lvovsky 2010-08-30 07:36:44 EDT
Be aware to volume format during reproducing.
Comment 10 Haim 2010-09-02 10:59:56 EDT
no repro. close as WORKSFORME

Note You need to log in before you can comment on or make changes to this bug.