Bug 62361 - backported CXX_EXIT macro causes code to bleed into confdefs.h
backported CXX_EXIT macro causes code to bleed into confdefs.h
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: autoconf (Show other bugs)
7.2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jens Petersen
Brian Brock
http://bugzilla.mozilla.org/show_bug....
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-03-30 02:25 EST by Chris Seawood
Modified: 2007-04-18 12:41 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-05-15 03:45:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Seawood 2002-03-30 02:25:16 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9+) Gecko/20020311

Description of problem:
This was originally reported in Mozilla's bug database at
http://bugzilla.mozilla.org/show_bug.cgi?id=134363 .  The problem is that
"#ifdef\ __cplusplus void\ exit\ \(int\)\; #endif" was winding up in the compile
line on solaris gcc builds.  This seems to stem from the backport of the
AC_PROG_CXX_EXIT_DECLARATION macro in bug 18829.  The only reason that I can
think of that we just noticed this is because the majority of the people who
work on configure.in still use RH6.2.  

Version-Release number of selected component (if applicable):
2.13-14

How reproducible:
Always

Steps to Reproduce:
1. On a solaris box with gcc, cvs -z3 -d
:pserver:anonymous@cvs-mirror.mozilla.org:/cvsroot co -r
ldapcsdk_50_client_branch -D "Fri Mar 29 23:14:45 PST 2002"
mozilla/directory/c-sdk && cd mozilla/directory/c-sdk &&  cvs -z3 up -r 5.0.2.5
configure
2. ./configure && make
3. (btw, the passwd for anoncvs is 'anonymous')

Actual Results:  gcc -o now.o -c     -Wall -pthreads -O -fPIC  -UDEBUG 
-DMOZILLA_CLIENT=1 -DNDEBUG=1 #ifdef\ __cplusplus void\ exit\ \(int\)\; #endif
-DXP_UNIX=1 -DSVR4=1 -DSYSV=1 -D__svr4=1 -D__svr4__=1 -DSOLARIS=1
-DHAVE_FCNTL_FILE_LOCKING=1 -D_PR_HAVE_OFF64_T=1 -D_LARGEFILE64_SOURCE=1
-DHAVE_LCHOWN=1 -DHAVE_STRERROR=1 -D_REENTRANT=1 -DHAVE_POINTER_LOCALTIME_R=1 
-DFORCE_PR_LOG -D_PR_PTHREADS -UHAVE_CVAR_BUILT_ON_SEM   now.c
gcc: No input files


Expected Results:  The entire project should have compiled without any extra
directives on the compile lines.

Additional info:
Comment 1 Jens Petersen 2002-04-12 03:00:44 EDT
(Btw how about using using autoconf-2.53?)

Anyway thanks for the report.
The solution seems to be to backport AC_OUTPUT_MAKE_DEFS too.
Comment 2 Chris Seawood 2002-04-12 11:41:45 EDT
Autoconf 2.5x doesn't work with the toplevel Mozilla configure.in ,
http://bugzilla.mozilla.org/show_bug.cgi?id=104642 , and generating ldap's
configure with autoconf 2.52 caused build problems on win32 a couple of weeks
ago so we're going to avoid that series for now.
Comment 3 Jens Petersen 2002-05-15 03:45:37 EDT
fix added to autoconf213-2.13-1.

Note You need to log in before you can comment on or make changes to this bug.