Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 623659 - Cannot clear flag using Web UI nor XMLRPC
Cannot clear flag using Web UI nor XMLRPC
Status: CLOSED NEXTRELEASE
Product: Bugzilla
Classification: Community
Component: Bugzilla General (Show other bugs)
3.6
All Linux
urgent Severity urgent (vote)
: ---
: ---
Assigned To: PnT DevOps Devs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-12 09:09 EDT by Ludek Smid
Modified: 2013-06-23 21:50 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-12 13:17:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
v1 to fix flag type issue (715 bytes, patch)
2010-08-12 09:42 EDT, Noura El hawary
dkl: review+
Details | Diff

  None (edit)
Description Ludek Smid 2010-08-12 09:09:08 EDT
Description of problem:

Cannot clear bug via Web UI. Setting flags to "+", "-", or "?" works.

Version-Release number of selected component (if applicable):

3.6

How reproducible:


Steps to Reproduce:
1. Go to https://partner-bugzilla.redhat.com/show_bug.cgi?id=621586
2. click cluster-4.7.z (or any other flag)
3. Clear it (set to "")
4. Click "Save Changes"

Actual results:

Shows page displaying:
"""
Software error:

Can't call method "type" on an undefined value at Bugzilla/Flag.pm line 1049.
"""

Expected results:

Flag is cleared.

Additional info:

The same error is displayed when using XMLRPC.
Comment 1 Noura El hawary 2010-08-12 09:42:34 EDT
Created attachment 438444 [details]
v1 to fix flag type issue

Thanks for identifying this issue.

Attached is a patch to fix the problem, I tested the patch on my local bugzilla and the problem was fixed. Please let me know what you think Dave.

the patch is against the 3.6 branch bugzilla.

Noura
Comment 2 David Lawrence 2010-08-12 13:17:40 EDT
Comment on attachment 438444 [details]
v1 to fix flag type issue

Thanks Noura. I went ahead and committed this to SVN as well.

Dave

Note You need to log in before you can comment on or make changes to this bug.