Bug 623664 - tiffinfo pc260001.tif segfaults on s390x and ppc64
tiffinfo pc260001.tif segfaults on s390x and ppc64
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: libtiff (Show other bugs)
6.0
All Linux
high Severity high
: rc
: ---
Assigned To: Petr Hracek
BaseOS QE - Apps
:
Depends On:
Blocks: 947775 1070830 1159820 1269889
  Show dependency treegraph
 
Reported: 2010-08-12 09:17 EDT by Ales Zelinka
Modified: 2015-10-21 04:32 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-21 04:32:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
pc260001.tif (914.57 KB, image/tiff)
2010-08-18 11:49 EDT, Ales Zelinka
no flags Details

  None (edit)
Description Ales Zelinka 2010-08-12 09:17:45 EDT
Description of problem:
running tiffinfo on the attached file segfaults on s390x and ppc (endianity problem?)

Version-Release number of selected component (if applicable):
libtiff-3.9.4-1.el6.ppc64

How reproducible:
always

Steps to Reproduce:
1. tiffinfo pc260001.tif
Comment 1 Tom Lane 2010-08-12 11:19:17 EDT
Um ... no attachment here ...
Comment 2 Ales Zelinka 2010-08-18 11:49:09 EDT
Created attachment 439416 [details]
pc260001.tif

Wouldn't be me if I hadn't forgotten to attach the file.
Comment 3 Tom Lane 2010-08-18 17:37:54 EDT
I've filed this upstream at http://bugzilla.maptools.org/show_bug.cgi?id=2258

I'm not clear on what a reasonable fix would be, and am inclined to consider it low-priority, since TIFFPrintDirectory is probably not used in any security-critical contexts.
Comment 4 Martin Cermak 2010-11-02 04:11:48 EDT
Observed again [1], [2]. Can we make some conclusion about our test [3] behaviour at the moment? 

[1] https://beaker.engineering.redhat.com/matrix/?toggle_nacks_on=on&job_ids=26980
[2] https://beaker.engineering.redhat.com/matrix/?toggle_nacks_on=on&job_ids=27396
[3] /CoreOS/libtiff/Regression/official-test-images
Comment 6 RHEL Product and Program Management 2011-01-07 11:01:53 EST
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.
Comment 10 RHEL Product and Program Management 2011-07-05 21:25:19 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.
Comment 12 Suzanne Yeghiayan 2012-02-14 18:02:06 EST
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.
Comment 15 RHEL Product and Program Management 2012-07-10 03:05:15 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 16 RHEL Product and Program Management 2012-07-10 19:50:51 EDT
This request was erroneously removed from consideration in Red Hat Enterprise Linux 6.4, which is currently under development.  This request will be evaluated for inclusion in Red Hat Enterprise Linux 6.4.
Comment 24 Ales Zelinka 2015-10-21 04:02:45 EDT
I can no longer reproduce this on libtiff-3.9.4-10.el6_5 (current version). Both s390x and ppc64 work ok. This bug can IMO be closed.
Comment 25 Petr Hracek 2015-10-21 04:32:59 EDT
Thanks. Closing it with CLOSED->CURRENTRELEASE.

Feel free to reopen it in case of troubles.

Note You need to log in before you can comment on or make changes to this bug.