Bug 62375 - Can't rebuild rpm-4.0.4-7x.src.rpm on 7.1
Can't rebuild rpm-4.0.4-7x.src.rpm on 7.1
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-03-30 14:08 EST by hjl
Modified: 2007-04-18 12:41 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-10 10:15:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
A patch (413 bytes, patch)
2002-03-31 03:06 EST, hjl
no flags Details | Diff

  None (edit)
Description hjl 2002-03-30 14:08:15 EST
I got

gcc -c -I. -I/export/rearden/rst/BUILD/rpm-4.0.4/lib
-I/export/rearden/rst/BUILD/rpm-4.0.4/rpmdb
-I/export/rearden/rst/BUILD/rpm-4.0.4/rpmio
-I/export/rearden/rst/BUILD/rpm-4.0.4/popt -fno-strict-aliasing -O2 -march=i386
-mcpu=i686     -DVERSION=\"0.32\" -DXS_VERSION=\"0.32\" -fPIC
-I/usr/lib/perl5/5.6.0/i386-linux/CORE -DRPM_MAJOR=4 -DRPM_MINOR=0 -DRPM_PATCH=2
-DRPM_VERSION=0x040002 RPM/Constants.c -o RPM/Constants.o
Constants.xs: In function `constant':
Constants.xs:19: `CHECKSIG_GPG' undeclared (first use in this function)
Constants.xs:19: (Each undeclared identifier is reported only once
Constants.xs:19: for each function it appears in.)
Constants.xs:21: `CHECKSIG_MD5' undeclared (first use in this function)
Constants.xs:23: `CHECKSIG_PGP' undeclared (first use in this function)
Constants.xs:47: `QUERY_FOR_CONFIG' undeclared (first use in this function)
Constants.xs:49: `QUERY_FOR_DOCS' undeclared (first use in this function)
Constants.xs:51: `QUERY_FOR_DUMPFILES' undeclared (first use in this function)
Constants.xs:53: `QUERY_FOR_LIST' undeclared (first use in this function)

The problem is Perl-RPM picks the wrong rpm binary to get the rpm version
string. It should use the rpm just build, not the one on the system.
Comment 1 Jeff Johnson 2002-03-30 14:56:20 EST
Perl-rpm is not self hosting.

Build without, install, build again.
Comment 2 hjl 2002-03-31 03:06:23 EST
Created attachment 51527 [details]
A patch
Comment 3 hjl 2002-03-31 03:08:29 EST
I submitted a patch. It may not be suitable in the Perl-RPM
package. But it can be used inside the rpm source and applied
from the spec file.
Comment 4 Jeff Johnson 2004-10-10 10:15:32 EDT
perl-RPM has been removed from rpm sub-packages.

Note You need to log in before you can comment on or make changes to this bug.