Bug 623827 - yum refuses update yelp and yelp-libs as this would require yelp (???)
yum refuses update yelp and yelp-libs as this would require yelp (???)
Product: Fedora
Classification: Fedora
Component: yelp (Show other bugs)
All Linux
low Severity medium
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2010-08-12 17:36 EDT by Michal Jaegermann
Modified: 2014-01-21 18:16 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2010-08-13 02:06:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
results of running 'yum --skip-broken -d4 update yelp\*' (2.82 KB, text/plain)
2010-08-12 17:36 EDT, Michal Jaegermann
no flags Details

  None (edit)
Description Michal Jaegermann 2010-08-12 17:36:56 EDT
Created attachment 438541 [details]
results of running 'yum --skip-broken -d4 update yelp\*'

Description of problem:

With the current rawhide 'yum update yelp\*' ends up with the following:

Resolving Dependencies
--> Running transaction check
---> Package yelp.x86_64 1:2.31.7-2.fc15 set to be updated
---> Package yelp-libs.x86_64 1:2.31.7-2.fc15 set to be updated
--> Processing Dependency: yelp = 2.31.7-2.fc15 for package: 1:yelp-libs-2.31.7-2.fc15.x86_64
--> Finished Dependency Resolution
Error: Package: 1:yelp-libs-2.31.7-2.fc15.x86_64 (rawhide)
           Requires: yelp = 2.31.7-2.fc15
           Removing: yelp-2.31.7-1.fc14.x86_64 (@rawhide/14)
               yelp = 2.31.7-1.fc14
           Updated By: 1:yelp-2.31.7-2.fc15.x86_64 (rawhide)
               yelp = 1:2.31.7-2.fc15

Eh?  So what is this error?  An output from
'yum --skip-broken -d4 update yelp\*' is attached but I still miss what makes yum unhappy.

Version-Release number of selected component (if applicable):
yum-3.2.28-2.fc15.noarch results in the following:

How reproducible:

Additional info:
The following suggestion is printed too by yum:
You could try running: rpm -Va --nofiles --nodigest

Such command ends up after a while with no output.
Comment 1 Michal Jaegermann 2010-08-12 18:06:17 EDT
Ahem, maybe this is really a bug in rpm or packages.  After retrieving those and running:

  rpm -vv -Fh yelp-2.31.7-2.fc15.x86_64.rpm yelp-libs-2.31.7-2.fc15.x86_64.rpm

brings (among other output):

D: package yelp-libs-1:2.31.7-2.fc15.x86_64 has unsatisfied Requires: yelp = 2.31.7-2.fc15

Does "Requires:" needs and explicit epoch if used?
Comment 2 Panu Matilainen 2010-08-13 02:06:16 EDT
It's a packaging bug and seems to have been fixed already:

* Thu Aug 12 2010 Matthias Clasen <mclasen@redhat.com> - 1:2.31.7-3
- Fix up dependencies for epoch

Note You need to log in before you can comment on or make changes to this bug.