Bug 623828 - IOCTL error messages in mock-1.1.3-1.fc13
IOCTL error messages in mock-1.1.3-1.fc13
Status: CLOSED DUPLICATE of bug 514440
Product: Fedora
Classification: Fedora
Component: mock (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: David Cantrell
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-12 17:38 EDT by Dominic Hopf
Modified: 2013-01-10 01:08 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-19 13:53:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dominic Hopf 2010-08-12 17:38:22 EDT
Description of problem:
I just successfully built a package update for jabberd in mock. Even if this seemed to be successful, there is some output claiming errors with IOCTL:

$ LANG=C /usr/bin/mock -r fedora-13-x86_64 --rebuild /home/dmaphy/rpmbuild/SRPMS/jabberd-2.2.10-1.fc13.src.rpm --resultdir=/home/dmaphy/RPMS/Fedora/13/x86_64/
INFO: mock.py version 1.1.3 starting...
State Changed: init plugins
INFO: selinux enabled
State Changed: start
INFO: Start(/home/dmaphy/rpmbuild/SRPMS/jabberd-2.2.10-1.fc13.src.rpm)  Config(fedora-13-x86_64)
State Changed: lock buildroot
State Changed: clean
State Changed: init
State Changed: lock buildroot
Mock Version: 1.1.3
INFO: Mock Version: 1.1.3
INFO: enabled root cache
State Changed: unpacking root cache
INFO: enabled yum cache
State Changed: cleaning yum metadata
INFO: enabled ccache
State Changed: running yum
State Changed: setup
State Changed: build
INFO: Done(/home/dmaphy/rpmbuild/SRPMS/jabberd-2.2.10-1.fc13.src.rpm) Config(fedora-13-x86_64) 1 minutes 50 seconds
INFO: Results and/or logs in: /home/dmaphy/RPMS/Fedora/13/x86_64/
INFO: Cleaning up build root ('clean_on_success=True')
State Changed: lock buildroot
State Changed: clean
chattr: Inappropriate ioctl for device while reading flags on /var/lib/mock/fedora-13-x86_64/root/proc
ERROR: Exception(/home/dmaphy/rpmbuild/SRPMS/jabberd-2.2.10-1.fc13.src.rpm) Config(fedora-13-x86_64) 1 minutes 52 seconds
INFO: Results and/or logs in: /home/dmaphy/RPMS/Fedora/13/x86_64/
INFO: Cleaning up build root ('clean_on_failure=True')
State Changed: lock buildroot
State Changed: clean
chattr: Inappropriate ioctl for device while reading flags on /var/lib/mock/fedora-13-x86_64/root/proc

ERROR: [Errno 1] Operation not permitted: '/var/lib/mock/fedora-13-x86_64/root/proc/asound/NVidia'

ERROR: The most common cause for this error is trying to run /usr/sbin/mock as an unprivileged user.
ERROR: Check your path to make sure that /usr/bin/ is listed before /usr/sbin, or manually run /usr/bin/mock to see if that fixes this problem.


Version-Release number of selected component (if applicable):
1.1.3-1.fc13

How reproducible:
Fully reproducible here for me.

Steps to Reproduce:
1. Build a package in mock
  
Actual results:
see output above.

Expected results:
there are no error messages and mock quits cleanly

Additional info:
$ echo $PATH
/usr/lib64/qt-3.3/bin:/usr/kerberos/sbin:/usr/kerberos/bin:/usr/lib64/ccache:/usr/local/bin:/usr/bin:/bin:/home/dmaphy/bin:/usr/local/sbin:/usr/sbin:/sbin

/usr/bin obviously is listed before /usr/sbin.

Running mock directly via /usr/bin/mock unfortunately also did not fix the issue.

Maybe hardware information is useful for you, please tell me what exactly you're interested in if so. So far here's my output from lspci:

$ lspci
00:00.0 RAM memory: nVidia Corporation MCP61 LPC Bridge (rev a1)
00:01.0 ISA bridge: nVidia Corporation MCP61 LPC Bridge (rev a2)
00:01.1 SMBus: nVidia Corporation MCP61 SMBus (rev a2)
00:01.2 RAM memory: nVidia Corporation MCP61 Memory Controller (rev a2)
00:02.0 USB Controller: nVidia Corporation MCP61 USB Controller (rev a3)
00:02.1 USB Controller: nVidia Corporation MCP61 USB Controller (rev a3)
00:04.0 PCI bridge: nVidia Corporation MCP61 PCI bridge (rev a1)
00:05.0 Audio device: nVidia Corporation MCP61 High Definition Audio (rev a2)
00:06.0 IDE interface: nVidia Corporation MCP61 IDE (rev a2)
00:07.0 Bridge: nVidia Corporation MCP61 Ethernet (rev a2)
00:08.0 IDE interface: nVidia Corporation MCP61 SATA Controller (rev a2)
00:08.1 IDE interface: nVidia Corporation MCP61 SATA Controller (rev a2)
00:09.0 PCI bridge: nVidia Corporation MCP61 PCI Express bridge (rev a2)
00:0b.0 PCI bridge: nVidia Corporation MCP61 PCI Express bridge (rev a2)
00:0c.0 PCI bridge: nVidia Corporation MCP61 PCI Express bridge (rev a2)
00:0d.0 VGA compatible controller: nVidia Corporation C61 [GeForce 7025 / nForce 630a] (rev a2)
00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] HyperTransport Technology Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Miscellaneous Control
01:06.0 Network controller: Texas Instruments ACX 111 54Mbps Wireless Interface
01:07.0 RAID bus controller: Integrated Technology Express, Inc. IT/ITE8212 Dual channel ATA RAID controller (rev 13)
Comment 1 Michal Schmidt 2010-08-19 03:34:07 EDT
Looks like the same problem as reported in https://bugzilla.redhat.com/show_bug.cgi?id=614440#c16
Comment 2 Clark Williams 2010-08-19 13:53:07 EDT
yeah, this should be fixed in the just-released mock-1.1.4

*** This bug has been marked as a duplicate of bug 514440 ***

Note You need to log in before you can comment on or make changes to this bug.