This service will be undergoing non-disruptive maintenance at 07:20 UTC, 2018-12-14. It is expected to last approximately 30 minutes
Bug 623850 - RFE: PATCH: support updating attachment flags
Summary: RFE: PATCH: support updating attachment flags
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: python-bugzilla (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
low
medium
Target Milestone: ---
Assignee: Will Woods
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-08-13 00:28 UTC by Dan Callaghan
Modified: 2013-02-16 15:35 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-16 15:35:28 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to add new method for updating attachment flags (1.87 KB, patch)
2010-08-13 00:28 UTC, Dan Callaghan
no flags Details | Diff

Description Dan Callaghan 2010-08-13 00:28:54 UTC
Created attachment 438565 [details]
patch to add new method for updating attachment flags

It would be useful if we could update attachment flags using python-bugzilla. This is now possible in RHBugzilla (since 3.4 I think?) using Flag.update:

https://bugzilla.redhat.com/docs/en/html/api/Bugzilla/WebService/Flag.html

Patch attached.

Comment 1 Cole Robinson 2013-01-31 22:53:15 UTC
Thanks for the patch Dan. Upstream code has changed quite a bit so it didn't apply, but the API is upstream now.

Comment 2 Cole Robinson 2013-02-16 15:35:28 UTC
Fixed in python-bugzilla-0.8.0-1.fc19


Note You need to log in before you can comment on or make changes to this bug.