Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 623963 - SyntaxError: invalid syntax in cmd_workflow_kernel.py
SyntaxError: invalid syntax in cmd_workflow_kernel.py
Status: CLOSED CURRENTRELEASE
Product: Beaker
Classification: Community
Component: command line (Show other bugs)
0.5
All Linux
high Severity high (vote)
: 0.5.55
: ---
Assigned To: Raymond Mancy
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-13 06:01 EDT by Alexander Todorov
Modified: 2015-05-03 21:28 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-27 03:03:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexander Todorov 2010-08-13 06:01:29 EDT
Description of problem:

$ bkr
Traceback (most recent call last):
  File "/usr/bin/bkr", line 7, in ?
    sys.exit(
  File "/usr/lib/python2.4/site-packages/pkg_resources.py", line 277, in load_entry_point
    return get_distribution(dist).load_entry_point(group, name)
  File "/usr/lib/python2.4/site-packages/pkg_resources.py", line 2180, in load_entry_point
    return ep.load()
  File "/usr/lib/python2.4/site-packages/pkg_resources.py", line 1913, in load
    entry = __import__(self.module_name, globals(),globals(), ['__name__'])
  File "/usr/lib/python2.4/site-packages/bkr/client/main.py", line 18, in ?
    CommandContainer.register_module(bkr.client.commands, prefix="cmd_")
  File "/usr/lib/python2.4/site-packages/kobo/plugins.py", line 135, in register_module
    __import__(module.__name__, {}, {}, module_list)
  File "/usr/lib/python2.4/site-packages/bkr/client/commands/cmd_workflow_kernel.py", line 24
    class Matrixes():
                   ^
SyntaxError: invalid syntax


Version-Release number of selected component (if applicable):
beaker-client-0.5.52-3.el5
beaker-redhat-0.1.13-1.el5

How reproducible:
always

Steps to Reproduce:
1. Install beaker-redhat package and run bkr command.
2.
3.
  
Actual results:
bkr command is unusable, not even help works

Expected results:
bkr works. At least if some command is broken this doesn't affect other commands. 

Additional info:
Comment 4 Marian Csontos 2010-08-23 06:45:48 EDT
As I do not have an EL5 machine with kerberos set, could you try following build please:

  https://brewweb.devel.redhat.com//buildinfo?buildID=141315

which is the snapshot of:

  http://git.engineering.redhat.com/?p=users/mcsontos/beaker-redhat.git;a=summary

It now runs on EL5, but does not connect...
Comment 5 Alexander Todorov 2010-08-23 07:27:49 EDT
This works for me. No traceback.
Comment 6 Marian Csontos 2010-08-23 08:20:31 EDT
Thanks. I will brew it for Wednesday's update.
Comment 11 Raymond Mancy 2010-08-27 03:03:02 EDT
Harness synch'ed

Note You need to log in before you can comment on or make changes to this bug.