Bug 62399 - USB keyboard not recognised on boot
USB keyboard not recognised on boot
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: kernel (Show other bugs)
skipjack-beta1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Pete Zaitcev
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-03-30 23:25 EST by Need Real Name
Modified: 2007-04-18 12:41 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-10 05:21:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Log from bad boot (2.11 KB, text/plain)
2002-03-30 23:26 EST, Need Real Name
no flags Details
Logs from a successful boot (kernel-2.4.18-0.4) (1.57 KB, text/plain)
2002-03-30 23:27 EST, Need Real Name
no flags Details
/proc/bus/usb/devices from the working kernel (1.89 KB, text/plain)
2002-04-05 18:53 EST, Need Real Name
no flags Details
/proc/modules from a working kernel (2.45 KB, text/plain)
2002-04-05 18:53 EST, Need Real Name
no flags Details
Arjan's devices (2.67 KB, text/plain)
2002-04-08 13:14 EDT, Pete Zaitcev
no flags Details
Arjan's modules (994 bytes, text/plain)
2002-04-08 13:16 EDT, Pete Zaitcev
no flags Details

  None (edit)
Description Need Real Name 2002-03-30 23:25:15 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.0.0; Linux)

Description of problem:
In kernel-2.4.18-0.8 my Happy Hacking USB keyboard is not recognised, it works fine in kernel-2.4.18-0.4 and all enigma kernels. The errors from a bad boot are in error.txt, a normal boot is in success.txt.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Boot with USB mouse and keyboard attached
 

Actual Results:  Keyboard does not work!

Expected Results:  Keyboard works.

Additional info:
Comment 1 Need Real Name 2002-03-30 23:26:01 EST
Created attachment 51524 [details]
Log from bad boot
Comment 2 Need Real Name 2002-03-30 23:27:24 EST
Created attachment 51525 [details]
Logs from a successful boot (kernel-2.4.18-0.4)
Comment 3 Arjan van de Ven 2002-03-31 03:04:01 EST
My keyboard is a HH one too; I'll try this
Comment 4 Arjan van de Ven 2002-04-05 09:54:07 EST
Interesting; I'm now using 2.4.18-0.13 and my HH usb keyboard just works.
Pete: any idea what could be going on ?
Comment 5 Pete Zaitcev 2002-04-05 13:15:48 EST
Leaving Arjan on cc: because he has the hardware.

It's not a problem with the keyboard as such, but with a hub
(which may be built into the keyboard).
Comment 6 Arjan van de Ven 2002-04-05 13:24:13 EST
HH keyboards have an "on board" hub and 2 outputs
Comment 7 Pete Zaitcev 2002-04-05 13:30:25 EST
Thanks for the logs; Now I would like to see contents of
/proc/bus/usb/devices and /proc/modules for a working kernel.
Non-working may be interesting too (to see what's missing).
Comment 8 Need Real Name 2002-04-05 18:53:05 EST
Created attachment 52504 [details]
/proc/bus/usb/devices from the working kernel
Comment 9 Need Real Name 2002-04-05 18:53:48 EST
Created attachment 52505 [details]
/proc/modules from a working kernel
Comment 10 Pete Zaitcev 2002-04-08 12:25:39 EDT
oops, I thought I already took the bug. Taking now.
Fred, thanks for the attachements, they are exactly what I need.
Comment 11 Pete Zaitcev 2002-04-08 13:14:48 EDT
Created attachment 52704 [details]
Arjan's devices
Comment 12 Pete Zaitcev 2002-04-08 13:16:38 EDT
Created attachment 52705 [details]
Arjan's modules
Comment 13 Need Real Name 2002-04-10 03:01:24 EDT
I can confirm that 2.4.18-0.13 just works.
Comment 14 Arjan van de Ven 2002-04-10 05:21:46 EDT
I hate bugs that automatically fix themselves ;(

Note You need to log in before you can comment on or make changes to this bug.