Bug 62403 - /boot/grub/grub.conf violates the FHS
/boot/grub/grub.conf violates the FHS
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: grub (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Glen Foster
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-03-31 01:25 EST by Chris Ricker
Modified: 2007-04-18 12:41 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-31 23:19:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Ricker 2002-03-31 01:25:20 EST
The LSB mandates that all boot loader config files be in /etc with all the other
config files.  From page 9 of LSB-2.2:

3.5 /boot : Static files of the boot loader
3.5.1 Purpose
This directory contains everything required for the boot process except
configuration files and the map
installer. Thus /boot stores data that is used before the kernel begins
executing user-mode programs.
This may include saved master boot sectors, sector map files, and other data
that is not directly edited by
hand.2

2.    Programs necessary to arrange for the boot loader to be able to boot a
file must be placed in /sbin. Configuration files for
boot loaders must be placed in /etc.
Comment 1 Jeremy Katz 2002-03-31 23:18:57 EST
It's the FHS, not the LSB.  And this is clearly a case of standards
drain-bamage.because for boot loaders that are sane and can actually read their
config files off the filesystem, the config file has to be in the same physical
partition as the kernels and boot loader images.  We do, though, provide a
symlink of /etc/grub.conf to help out somewhat.

Now to figure out the proper channels for getting brokenness out of the FHS (the
LSB at least has a bug database :-)

Note You need to log in before you can comment on or make changes to this bug.