Bug 62405 - cups documentation / web management broken
Summary: cups documentation / web management broken
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: cups (Show other bugs)
(Show other bugs)
Version: 7.3
Hardware: i386 Linux
medium
high
Target Milestone: ---
Assignee: wdovlrrw
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 61901
TreeView+ depends on / blocked
 
Reported: 2002-03-31 06:51 UTC by Chris Ricker
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-03 12:28:20 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Chris Ricker 2002-03-31 06:51:10 UTC
/usr/share/doc/cups-1.1.14/index.html (ie, the main web management page) is
mostly broken.

It links to the CGIs for admin, classes, jobs, and printers, but all those links
are broken, since the CGIs are installed in /usr/lib/cups/cgi-bin, not in
/usr/share/doc/cups-1.1.14 where it's looking for them.

Comment 1 Bernhard Rosenkraenzer 2002-04-03 12:28:15 UTC
This is *not* the main web management page.   
The web management page is http://localhost:631 (you can't execute CGIs by pointing a   
browser at file:/something and expecting it to work).   
  
I agree that having the file there is confusing, though.

Comment 2 Bernhard Rosenkraenzer 2002-04-03 13:13:49 UTC
Fixed in 1.1.14-12: 
I've added new html files in subdirectories of /usr/share/doc/cups-1.1.14/ that redirect 
you to the correct place if you mistake /usr/share/doc/cups-1.1.14/index.html for the CUPS 
admin page. 



Note You need to log in before you can comment on or make changes to this bug.