Bug 624128 - dhcpd won't start up.
dhcpd won't start up.
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: dhcp (Show other bugs)
14
All Linux
low Severity medium
: ---
: ---
Assigned To: Jiri Popelka
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-13 14:35 EDT by Dave Jones
Modified: 2015-01-04 17:31 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-13 20:01:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dave Jones 2010-08-13 14:35:55 EDT
when I upgraded my f13 router to the latest snapshot of f14, dhcpd stopped working.  The log isn't really helpful...

Aug 13 14:32:12 firewall dhcpd: Internet Systems Consortium DHCP Server 4.2.0
Aug 13 14:32:12 firewall dhcpd: Copyright 2004-2010 Internet Systems Consortium.
Aug 13 14:32:12 firewall dhcpd: All rights reserved.
Aug 13 14:32:12 firewall dhcpd: For info, please visit https://www.isc.org/software/dhcp/
Aug 13 14:32:12 firewall dhcpd: Not searching LDAP since ldap-server, ldap-port and ldap-base-dn were not specified in the config file
Aug 13 14:32:12 firewall dhcpd: ddns-update-style ad_hoc no longer supported
Aug 13 14:32:12 firewall dhcpd: 
Aug 13 14:32:12 firewall dhcpd: This version of ISC DHCP is based on the release available
Aug 13 14:32:12 firewall dhcpd: on ftp.isc.org.  Features have been added and other changes
Aug 13 14:32:12 firewall dhcpd: have been made to the base software release in order to make
Aug 13 14:32:12 firewall dhcpd: it work better with this distribution.
Aug 13 14:32:12 firewall dhcpd: 
Aug 13 14:32:12 firewall dhcpd: Please report for this software via the Red Hat Bugzilla site:
Aug 13 14:32:12 firewall dhcpd:     http://bugzilla.redhat.com
Aug 13 14:32:12 firewall dhcpd: 
Aug 13 14:32:12 firewall dhcpd: exiting.


This is with selinux in non-enforcing mode.    If I leave it enforcing, I get a bonus message...

Aug 13 14:30:42 firewall dhcpd: Can't initialize context: permission denied
Comment 1 Dave Jones 2010-08-13 20:01:30 EDT
removing the ddns-update-style line from my dhcpd.conf made it start up.

Note You need to log in before you can comment on or make changes to this bug.