Bug 62413 - Font setting have no effect on some locales
Font setting have no effect on some locales
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: gtk+ (Show other bugs)
7.2
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Owen Taylor
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-03-31 07:38 EST by Harri Haataja
Modified: 2007-04-18 12:41 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-10 13:01:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Harri Haataja 2002-03-31 07:38:58 EST
Description of Problem:
Font setting have no effect on some locales. Neither from gnomecc (which doesn't
even preview though it allows changing the font) not from gtkrcs.
XMMS isn't affected (has its own font dialogs anyway) and font selectors work ok.
The problem is hard to go around since a lot of applications that should have
the settings are started from the panel.

Version-Release number of selected component (if applicable):
gtk+-1.2.10-11
gnome-core-1.4.0.4-38
gnome-libs-1.2.13-16
control-center-1.4.0.1-19
XFree86-4.1.0-15

How Reproducible:
Always.

Steps to Reproduce:
1. export locales
2. startx
3. observe default font and/or try to change it

Actual Results:
No font change if using some locales, some do work.

Expected Results:
The font entered in dialog to be used in Gtk all around =)

Additional Information:
The locale setting I've had:
LANG=en_GB
LC_CTYPE=fi_FI@euro
LC_NUMERIC=en_GB.utf8
LC_TIME=en_GB.utf8
LC_COLLATE=fi_FI@euro
LC_MONETARY=fi_FI.utf8@euro
LC_MESSAGES=en_GB
LC_PAPER=fi_FI.utf8@euro
LC_NAME=fi_FI@euro
LC_ADDRESS=fi_FI@euro
LC_TELEPHONE=fi_FI.utf8@euro
LC_MEASUREMENT=fi_FI.utf8@euro
LC_IDENTIFICATION=fi_FI.utf8@euro
LC_ALL=

If locales are all changed to fi_FI.utf8@euro, the fonts work but a lot of other
things (screen, irssi, terminals, console, man..) break. Leaving unset also works.
Comment 1 Owen Taylor 2002-04-10 13:00:59 EDT
I'm not sure these locale settings make sense; if you want 
a ISO-8859-15 locale with finish locale settings and
english messages, I'd expect:

LANG=fi_FI@euro
LC_MESSAGES=en_GB

The encoding (utf8 vs. the default) shouldn't make any
difference for anything but CTYPE. 

Anyways, this is probably basically unrelated to your
problem.

The reason that font
settings aren't working through the control center is that
the /etc/gtk/gtkrc.iso885915 file sets a fontset, not a 
font, and this overrides the 'font' set by the control center.
This is a known defect, that is reather hard to fix. GTK+-2.0
eliminates the problem entirely, and the need for the user
to worry about font encodings.

If you edit your .gtkrc manaully and change font= to fontset=
the setting should take affect.
Comment 2 Owen Taylor 2002-04-12 17:52:34 EDT
control-center-1.4.0.1-30 writes fontset=, not font= and should fix
this problem.

Note You need to log in before you can comment on or make changes to this bug.