Bug 624166 - megaraid_sas driver fails to load on x3650 M3
megaraid_sas driver fails to load on x3650 M3
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: realtime-kernel (Show other bugs)
1.2
All Linux
low Severity urgent
: ---
: ---
Assigned To: Clark Williams
David Sommerseth
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-13 17:56 EDT by Darren Hart
Modified: 2016-05-22 19:30 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-03-30 18:36:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
kernel-rt-2.6.24.7-162.el5rt.x86_64.rpm (16.35 MB, application/octet-stream)
2011-03-26 11:16 EDT, IBM Bug Proxy
no flags Details

  None (edit)
Description Darren Hart 2010-08-13 17:56:05 EDT
Trying to boot 2.6.24.7-149.el5rt (and -146 and -147) on an IBM System x3650 M3
results in the following failure. It appears to be a problem with the
megaraid_sas driver which doesn't detect the sas disks. Comparing the
megaraid_sas version from -149 and RHEL5.5, I see RHEL5.5 has a much newer
driver.

Apparently there are multiple storage controllers that can be configured with
these systems. In this case, we have a:

dmesg:
megasas: 00.00.04.17-RH1 Wed. Nov. 25, 11:41:51 PST 2009
megasas: 0x1000:0x0073:0x1014:0x03b1: bus 1:slot 0:func 0

lspci -n -s 1:0.0
01:00.0 0104: 1000:0073 (rev 02)

Te following patch, tested via the -162 kernel, addresses the issue:

+#define        PCI_DEVICE_ID_LSI_SAS0073SKINNY         0x0073

I'll try to patch,build,boot with it tomorrow:

commit 879111224d0784eab623fe8130a1f4481e0e1966
Author: Yang, Bo <Bo.Yang@lsi.com>
Date:   Tue Oct 6 14:31:54 2009 -0600

    [SCSI] megaraid_sas: Add new megaraid SAS 2 controller support to the
driver

    Add the new megaraid sas 2 controller to the driver.  megaraid sas2 is
    LSI next generation SAS products.  driver add the interface to support
    this product.

    Signed-off-by Bo Yang<bo.yang@lsi.com>
    Signed-off-by: James Bottomley <James.Bottomley@suse.de>

Without this patch:
[root@localhost ~]# modinfo
/lib/modules/2.6.24.7-149.el5rt/kernel/drivers/scsi/megaraid/megaraid_sas.ko 
filename:      
/lib/modules/2.6.24.7-149.el5rt/kernel/drivers/scsi/megaraid/megaraid_sas.ko
description:    LSI MegaRAID SAS Driver
author:         megaraidlinux@lsi.com
version:        00.00.03.16-rc1
license:        GPL
srcversion:     4F236D747E5DFBB52276C1D
alias:          pci:v00001028d00000015sv*sd*bc*sc*i*
alias:          pci:v00001000d00000413sv*sd*bc*sc*i*
alias:          pci:v00001000d00000079sv*sd*bc*sc*i*
alias:          pci:v00001000d00000078sv*sd*bc*sc*i*
alias:          pci:v00001000d00000060sv*sd*bc*sc*i*
alias:          pci:v00001000d00000411sv*sd*bc*sc*i*
depends:        scsi_mod
vermagic:       2.6.24.7-149.el5rt SMP preempt mod_unload 
parm:           poll_mode_io:Complete cmds from IO path, (default=0) (int)


[root@localhost ~]# modinfo megaraid_sas
filename:      
/lib/modules/2.6.18-194.el5/kernel/drivers/scsi/megaraid/megaraid_sas.ko
description:    LSI MegaRAID SAS Driver
author:         megaraidlinux@lsi.com
version:        00.00.04.17-RH1
license:        GPL
srcversion:     04AF5F5C6BA1B7EFD29FB99
alias:          pci:v00001028d00000015sv*sd*bc*sc*i*
alias:          pci:v00001000d00000413sv*sd*bc*sc*i*
alias:          pci:v00001000d0000007Csv*sd*bc*sc*i*
alias:          pci:v00001000d00000071sv*sd*bc*sc*i*
alias:          pci:v00001000d00000073sv*sd*bc*sc*i*
alias:          pci:v00001000d00000079sv*sd*bc*sc*i*
alias:          pci:v00001000d00000078sv*sd*bc*sc*i*
alias:          pci:v00001000d00000060sv*sd*bc*sc*i*
alias:          pci:v00001000d00000411sv*sd*bc*sc*i*
depends:        scsi_mod
vermagic:       2.6.18-194.el5 SMP mod_unload gcc-4.1
parm:           poll_mode_io:Complete cmds from IO path, (default=0) (int)
module_sig:    
883e3504ba0378078ccfeaa942826a112b22d098b64a4317797e421de2df5ec183eb5f27a8f3a80a0d3cec2b396a621a0a8e4994d51d140f72030c264

Dmesg:
...
Loading mbcache.ko module
Loading jbd.ko module
Loading ext3.ko module
Loading scsi_mod.ko moSCSI subsystem initialized
dule
Loading sd_mod.kDriver 'sd' needs updating - please use bus_type methods
o module
Loading megaraidmegasas: 00.00.03.16-rc1 Thu. Nov. 07 10:09:32 PDT 2007
_sas.ko module
Loading shpchp.kshpchp: Standard Hot Plug PCI Controller Driver version: 0.4
o module
Loading libata.ko module
Loading ata_piix.ko module
ata_piix 0000:00:1f.2: MAP [ P0 P2 P1 P3 ]
ACPI: PCI Interrupt 0000:00:1f.2[A] -> GSI 16 (level, low) -> IRQ 16
scsi0 : ata_piix
scsi1 : ata_piix
ata1: SATA max UDMA/133 cmd 0x1f0 ctl 0x3f6 bmdma 0x20f0 irq 14
ata2: SATA max UDMA/133 cmd 0x170 ctl 0x376 bmdma 0x20f8 irq 15
ata1.01: failed to IDENTIFY (device reports invalid type, err_mask=0x0)
ata1: failed to recover some devices, retrying in 5 secs
usb 5-2: new full speed USB device using uhci_hcd and address 2
usb 5-2: configuration #1 chosen from 2 choices
usb 7-2: new low speed USB device using uhci_hcd and address 2
usb 7-2: configuration #1 chosen from 1 choice
input: USBPS2 as /class/input/input4
input,hidraw3: USB HID v1.00 Keyboard [USBPS2] on usb-0000:00:1d.2-2
input: USBPS2 as /class/input/input5
input,hidraw4: USB HID v1.00 Mouse [USBPS2] on usb-0000:00:1d.2-2
ata1.00: ATAPI: DVD-ROM UJDA782, WA84, max UDMA/33
ata1.00: configured for UDMA/33
scsi 0:0:0:0: CD-ROM            MATSHITA DVD-ROM UJDA782  WA84 PQ: 0 ANSI: 5
ata_piix 0000:00:1f.5: MAP [ P0 -- P1 -- ]
ACPI: PCI Interrupt 0000:00:1f.5[C] -> GSI 21 (level, low) -> IRQ 21
scsi2 : ata_piix
scsi3 : ata_piix
ata3: SATA max UDMA/133 cmd 0x2108 ctl 0x2124 bmdma 0x20d0 irq 21
ata4: SATA max UDMA/133 cmd 0x2100 ctl 0x2120 bmdma 0x20d8 irq 21
Waiting for driver initialization.
Scanning and configuring dmraid supported devices
Trying to resKernel panic - not syncing: Attempted to kill init!
Pid: 1, comm: init Not tainted 2.6.24.7-147.el5rt #1

Call Trace:
 [<ffffffff8103dd50>] panic+0xaf/0x160
ume from /dev/sd [<ffffffff81060ac9>] ? rt_up_read+0x9/0xb
 [<ffffffff8128c3bc>] ? do_page_fault+0x3f6/0x76d
a6
Unable to ac [<ffffffff81138bc9>] ? lock_list_del_init+0x7c/0xaf
 [<ffffffff81056e0a>] ? blocking_notifier_call_chain+0xf/0x11
 [<ffffffff8104156c>] do_exit+0x8d/0x840
 [<ffffffff81041dae>] sys_exit_group+0x0/0x14
 [<ffffffff81041dc0>] sys_exit_group+0x12/0x14
 [<ffffffff8100c23e>] system_call_ret+0x0/0x5
ss resume devi
              ce (/dev/sda6)
Creating root device.
Mounting root filesystem.
mount: could not find filesystem '/dev/root'
Setting up other filesystems.
Setting up new root fs
setuproot: moving /dev failed: No such file or directory
no fstab.sys, mounting internal defaults
setuproot: error mounting /proc: No such file or directory
setuproot: error mounting /sys: No such file or directory
Switching to new root and running init.
unmounting old /dev
unmounting old /proc
unmounting old /sys
switchroot: mount failed: No such file or directory
Comment 1 Darren Hart 2010-08-13 17:57:12 EDT
Raising priority as customers are currently asking for a fix and don't want to wait for two erratas to be released. Please consider making -162 available as a hotfix.
Comment 2 Luis Claudio R. Goncalves 2010-08-13 23:04:55 EDT
Patch bz554664-scsi-megaraid_sas-add-new-megaraid_sas-2-controller-support.patch, backport of upstream commit 879111224d0784eab623fe8130a1f4481e0e1966, has been added to kernel 2.6.24.7-162.el5rt.
Comment 4 IBM Bug Proxy 2011-03-26 11:14:40 EDT
------- Comment From lnx1138@linux.vnet.ibm.com 2010-08-19 15:49 EDT-------
Thanks a bunch Joe!

------- Comment From vernux@us.ibm.com 2010-09-21 12:44 EDT-------
Joe,

The kernel that you posted for the customer at
http://people.redhat.com/jkachuck/IT1285773/kernel-rt-2.6.24.7-162.el5rt.x86_64.rpm
is giving them issues because they don't have the matching kernel-rt-firmware package.  This is what they see:

[root@ibmx3550a leeb]# rpm -ivh kernel-rt-2.6.24.7-162.el5rt.x86_64.rpm
error: Failed dependencies:
kernel-rt-firmware is needed by kernel-rt-2.6.24.7-162.el5rt.x86_64

Can you post the firmware package in the same place for them as well?
Comment 5 IBM Bug Proxy 2011-03-26 11:16:01 EDT
Created attachment 487806 [details]
kernel-rt-2.6.24.7-162.el5rt.x86_64.rpm
Comment 6 Clark Williams 2011-03-30 10:39:40 EDT
I thought this bug was closed?
Comment 7 IBM Bug Proxy 2011-03-30 11:21:14 EDT
------- Comment From lnx1138@linux.vnet.ibm.com 2011-03-30 11:04 EDT-------
(In reply to comment #23)
> I thought this bug was closed?

Hi Clark,

That may be the case. What you are seeing are the reposting of some old comments and attachments by our mirroring bridge as it resyncs after a migration that occurred this past weekend from RHCP to RHBZ.

Hi Vernon,

Can you confirm we can close this one out?
Comment 8 IBM Bug Proxy 2011-03-30 18:17:35 EDT
------- Comment From vernux@us.ibm.com 2011-03-30 18:01 EDT-------
Yes, we can close this.
Comment 9 Clark Williams 2011-03-30 18:36:32 EDT
closing

Note You need to log in before you can comment on or make changes to this bug.