Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 624210 - reports internal system error, does not update
reports internal system error, does not update
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: gnome-packagekit (Show other bugs)
13
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-14 09:22 EDT by Bernd Stramm
Modified: 2011-06-28 10:35 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-06-28 10:35:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bernd Stramm 2010-08-14 09:22:00 EDT
Description of problem:
When started from panel, or from menu (Administration->Software Update),
a pop-op appears saying
An internal system error has occured

A problem that we were not expecting has occured.
Please report this bug in your distributiong bugtracker with
the error description.

Details in the pop-up window says:


Error Type: <type 'exceptions.IndexError'>
Error Value: list index out of range
  File : /usr/share/PackageKit/helpers/yum/yumBackend.py, line 3408, in <module>
    main()
  File : /usr/share/PackageKit/helpers/yum/yumBackend.py, line 3405, in main
    backend.dispatcher(sys.argv[1:])
  File : /usr/lib/python2.6/site-packages/packagekit/backend.py, line 734, in dispatcher
    self.dispatch_command(args[0], args[1:])
  File : /usr/lib/python2.6/site-packages/packagekit/backend.py, line 603, in dispatch_command
    self.get_update_detail(package_ids)
  File : /usr/share/PackageKit/helpers/yum/yumBackend.py, line 2849, in get_update_detail
    evr = _getEVR(version[1])




Version-Release number of selected component (if applicable):
yum info gnome-packagekit says:

Name        : gnome-packagekit
Arch        : x86_64
Version     : 2.30.3
Release     : 1.fc13
Size        : 9.0 M
Repo        : installed
From repo   : updates
Summary     : Session applications to manage packages
URL         : http://www.packagekit.org
License     : GPLv2+
Description : gnome-packagekit provides session applications for the PackageKit
            : API. There are several utilities designed for installing, updating
            : and removing packages on your system.


How reproducible:

Start "Software Update" from menu, or from panel when notification icon is present


Steps to Reproduce:
1. Start Program
2.
3.
  
Actual results:

Error message window appears, and update does not work.
This repeats every time gnome-pacakgekit is run.


Expected results:

package is updated


Additional info:
Comment 1 Bernd Stramm 2010-08-14 12:26:39 EDT
Perhaps it is related to a package being present in 2 different repos. I have no idea if that is the underlying problem, but there is a package like that.
When it appears in the update list, this problem happens.

Loaded plugins: presto, refresh-packagekit
Installed Packages
Name        : xdg-utils
Arch        : noarch
Version     : 1.0.2
Release     : 20.20100709.fc13
Size        : 214 k
Repo        : installed
From repo   : updates
Summary     : Basic desktop integration functions
URL         : http://portland.freedesktop.org/
License     : MIT
Description : The xdg-utils package is a set of simple scripts that provide
            : basic desktop integration functions for any Free Desktop, such as
            : Linux. They are intended to provide a set of defacto standards.
            : This means that:
            : *  Third party software developers can rely on these xdg-utils
            :    for all of their simple integration needs.
            : *  Developers of desktop environments can make sure that their
            :    environments are well supported
            : *  Distribution vendors can provide custom versions of these
            :    utilities
            : 
            : The following scripts are provided at this time:
            : * xdg-desktop-menu      Install desktop menu items
            : * xdg-desktop-icon      Install icons to the desktop
            : * xdg-icon-resource     Install icon resources
            : * xdg-mime              Query information about file type handling
            :   and install descriptions for new file types
            : * xdg-open              Open a file or URL in the user's preferred
            :   application
            : * xdg-email             Send mail using the user's preferred
            :   e-mail composer
            : * xdg-screensaver       Control the screensaver

Available Packages
Name        : xdg-utils
Arch        : noarch
Version     : 1.0.2
Release     : 36.2
Size        : 52 k
Repo        : openSUSE_Tools
Summary     : Utilities to uniformly interface desktop environments
URL         : http://portland.freedesktop.org/
License     : X11/MIT
Description : The xdg-utils package is a set of simple scripts that provide
            : basic desktop integration functions for any Free Desktop, such as
            : Linux.
            : 
            : They are intended to provide a set of defacto standards.  This
            : means that: *  Third party software developers can rely on these
            :    xdg-utils for all of their simple integration needs.
            : 
            : *  Developers of desktop environments can make sure that their
            :    environments are well supported
            : 
            : If a desktop developer wants to be certain that their environment
            : functions with all third party software, then can simply make sure
            : that these utilities work properly in their environment.
Comment 2 Richard Hughes 2010-09-23 04:37:37 EDT
Does this still happen? What version yum and PackageKit do you have installed? Thanks.
Comment 3 Bernd Stramm 2010-09-23 11:45:32 EDT
Yes, still happening.

yum info PackageKit yum says this:

Installed Packages

Name        : PackageKit

Arch        : x86_64

Version     : 0.6.6

Release     : 2.fc13

Size        : 2.4 M

Repo        : installed

From repo   : updates

Summary     : Package management service

URL         : http://www.packagekit.org

License     : GPLv2+ and LGPLv2+

Description : PackageKit is a D-Bus abstraction layer that allows the session

            : user to manage packages in a secure way using a cross-distro,

            : cross-architecture API.



Name        : yum

Arch        : noarch

Version     : 3.2.28

Release     : 4.fc13

Size        : 4.2 M

Repo        : installed

From repo   : updates

Summary     : RPM installer/updater

URL         : http://yum.baseurl.org/

License     : GPLv2+

Description : Yum is a utility that can check for and automatically download and

            : install updated RPM packages. Dependencies are obtained and

            : downloaded automatically, prompting the user for permission as

            : necessary.



]0;bernd@pirx:~bernd@pirx 11:43:37 ~ $ exit

exit


Script done on Thu 23 Sep 2010 11:43:42 AM EDT
Comment 4 Rejean Groleau 2010-11-24 09:49:10 EST
I have exactly the same problem,
here's my "yum info gnome-packagekit":

Name        : gnome-packagekit
Arch        : x86_64
Version     : 2.30.3
Release     : 1.fc13
Size        : 9.0 M
Repo        : installed
From repo   : updates

Here is my list of repos from "ls /etc/yum.repos.d":
fedora.repo
fedora-updates.repo
fedora-updates-testing.repo
hudson.repo

Just in case they're related.
Comment 5 Bug Zapper 2011-06-01 07:27:20 EDT
This message is a reminder that Fedora 13 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 13.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '13'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 13's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 13 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 6 Bug Zapper 2011-06-28 10:35:27 EDT
Fedora 13 changed to end-of-life (EOL) status on 2011-06-25. Fedora 13 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.