Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 624233 - pychess crashes when clicking on Settings menu
pychess crashes when clicking on Settings menu
Status: CLOSED DUPLICATE of bug 598062
Product: Fedora
Classification: Fedora
Component: pychess (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Thomas Spura
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-14 19:06 EDT by Jonathan Underwood
Modified: 2010-08-15 12:36 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-15 07:59:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jonathan Underwood 2010-08-14 19:06:33 EDT
Description of problem:
If you click on the settings menu during a game (in this case playing the pychess engine at level 3, not that that seems to matter), abrtd detects a crash.

Abrtd reports:

Package:    	pychess-0.10-0.5.20100511hg.fc13
Latest Crash:	Sat 14 Aug 2010 23:51:38 
Command:    	/usr/bin/python /usr/bin/pychess
Reason:     	preferencesDialog.py:309:<lambda>:AttributeError: 'NoneType' object has no attribute 'startswith'
Comment:    	

Package:    	pychess-0.10-0.5.20100511hg.fc13
Latest Crash:	Sat 14 Aug 2010 23:59:48 
Command:    	/usr/bin/python -u /usr/lib/python2.6/site-packages/pychess/Players/PyChess.py
Reason:     	PyChess.py:252:run:EOFError: EOF when reading a line
Comment:    	None
Bug Reports:	




Version-Release number of selected component (if applicable):
pychess-0.10-0.5.20100511hg.fc13.noarch

How reproducible:
Every time

Steps to Reproduce:
1.Start a game
2.Click on Settings menu
3.
  
Actual results:
Crash

Expected results:
No crash

Additional info:
I've also reported this upstream:

http://code.google.com/p/pychess/issues/detail?id=573

However, I suspect their response will be "please try a more recent checkout"
Comment 1 Jonathan Underwood 2010-08-14 19:08:44 EDT
More complete backtrace:

$ pychess
no stock_draw-rounded-square-unfilled icon in icon-theme-gnome
no stock_draw-rounded-square icon in icon-theme-gnome
/usr/lib/python2.6/site-packages/pychess/System/uistuff.py:374: GtkWarning: GtkSpinButton: setting an adjustment with non-zero page size is deprecated
  self.glade = gtk.glade.XML(addDataPrefix("glade/%s" % filename))
Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/pychess/widgets/preferencesDialog.py", line 309, in <lambda>
    lambda data: data[3].startswith("audio/"))
AttributeError: 'NoneType' object has no attribute 'startswith'
Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/pychess/widgets/preferencesDialog.py", line 309, in <lambda>
    lambda data: data[3].startswith("audio/"))
AttributeError: 'NoneType' object has no attribute 'startswith'
Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/pychess/widgets/preferencesDialog.py", line 309, in <lambda>
    lambda data: data[3].startswith("audio/"))
AttributeError: 'NoneType' object has no attribute 'startswith'
Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/pychess/widgets/preferencesDialog.py", line 309, in <lambda>
    lambda data: data[3].startswith("audio/"))
AttributeError: 'NoneType' object has no attribute 'startswith'
Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/pychess/widgets/preferencesDialog.py", line 309, in <lambda>
    lambda data: data[3].startswith("audio/"))
AttributeError: 'NoneType' object has no attribute 'startswith'
Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/pychess/widgets/preferencesDialog.py", line 309, in <lambda>
    lambda data: data[3].startswith("audio/"))
AttributeError: 'NoneType' object has no attribute 'startswith'
Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/pychess/widgets/preferencesDialog.py", line 309, in <lambda>
    lambda data: data[3].startswith("audio/"))
AttributeError: 'NoneType' object has no attribute 'startswith'
Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/pychess/widgets/preferencesDialog.py", line 309, in <lambda>
    lambda data: data[3].startswith("audio/"))
AttributeError: 'NoneType' object has no attribute 'startswith'
Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/pychess/widgets/preferencesDialog.py", line 309, in <lambda>
    lambda data: data[3].startswith("audio/"))
AttributeError: 'NoneType' object has no attribute 'startswith'
Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/pychess/widgets/preferencesDialog.py", line 309, in <lambda>
    lambda data: data[3].startswith("audio/"))
AttributeError: 'NoneType' object has no attribute 'startswith'
Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/pychess/widgets/preferencesDialog.py", line 309, in <lambda>
    lambda data: data[3].startswith("audio/"))
AttributeError: 'NoneType' object has no attribute 'startswith'
Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/pychess/widgets/preferencesDialog.py", line 309, in <lambda>
    lambda data: data[3].startswith("audio/"))
AttributeError: 'NoneType' object has no attribute 'startswith'
Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/pychess/widgets/preferencesDialog.py", line 309, in <lambda>
    lambda data: data[3].startswith("audio/"))
AttributeError: 'NoneType' object has no attribute 'startswith'
Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/pychess/widgets/preferencesDialog.py", line 309, in <lambda>
    lambda data: data[3].startswith("audio/"))
AttributeError: 'NoneType' object has no attribute 'startswith'
Comment 2 Thomas Spura 2010-08-15 07:59:41 EDT
Thanks for the bug report.

This bug is already reported at bug #598062, but not yet fixed, because of:
https://fedoraproject.org/wiki/Change_deadlines

I didn't want to update pychess and let it go stable for F-13 and break the update path, but because it seems there is much demand for it, I'll do it now...

*** This bug has been marked as a duplicate of bug 598062 ***
Comment 3 Jonathan Underwood 2010-08-15 12:36:43 EDT
Sorry for filing two bugs - what happened is, I tried to submit it via abrtd initially, and that finished with an obscure  xmlrpc error message, so I assumed the bug hadn't been filed, so I filed it by hand. But thanks for looking at the issue so promptly!

Note You need to log in before you can comment on or make changes to this bug.