Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 624295 - No libpcap-devel-static
No libpcap-devel-static
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: libpcap (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Miroslav Lichvar
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-15 15:36 EDT by Nigel Horne
Modified: 2010-08-16 04:45 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-16 04:19:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nigel Horne 2010-08-15 15:36:24 EDT
Description of problem:
There is no libpcap-devel-static package, so it is not possible to use mudflap to diagnose programs built using libpcap, since you should use "-static" with "-fmudflap".

Version-Release number of selected component (if applicable):
14:1.0.0-5.20091201git117cb5.fc13

How reproducible:
100%

Steps to Reproduce:
1.  rpm -qa | fgrep libpcap-devel-static
2.
3.
  
Actual results:
Nothing

Expected results:


Additional info:
Comment 1 Miroslav Lichvar 2010-08-16 04:19:02 EDT
Static libraries should be included only in exceptional circumstances, please see

http://fedoraproject.org/wiki/Packaging/Guidelines#Packaging_Static_Libraries

I don't think including a static libpcap only for debugging purposes would meet the guideline.
Comment 2 Nigel Horne 2010-08-16 04:32:32 EDT
Please would you explain to me how I can run mudflap on my program which uses libpcap?
Comment 3 Miroslav Lichvar 2010-08-16 04:41:11 EDT
Download libpcap srpm, compile the sources and use libpcap.a as needed.
Comment 4 Nigel Horne 2010-08-16 04:45:22 EDT
Ouch :-(

Note You need to log in before you can comment on or make changes to this bug.