Bug 624298 - wesnoth not reacting to mouse clicks
wesnoth not reacting to mouse clicks
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: wesnoth (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Gwyn Ciesla
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-15 16:00 EDT by Rik van Riel
Modified: 2010-08-15 20:03 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-15 20:03:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rik van Riel 2010-08-15 16:00:04 EDT
Description of problem:

Wesnoth is not reacting to mouse clicks.

Version-Release number of selected component (if applicable):

wesnoth-1.8.3-1.fc13.x86_64
SDL-1.2.14-6.fc13.x86_64

Steps to Reproduce:
1. start wesnoth
2. click any button (eg. Multiplayer)
3. ...
  
Actual results:

Wesnoth just sits there

Expected results:

Wesnoth runs the event associated with the button (eg. go into Multiplayer menu when I click the Multiplayer button)

Additional info:

Running "wesnoth --log-debug=gui/event" gives me this debugging info:

20100815 15:56:28 debug gui/event: Firing: SDL left button up.
20100815 15:56:28 debug gui/event: distributor mouse button left [mp_method_selection]: SDL left button up.
20100815 15:56:28 warning gui/event: distributor mouse button left [mp_method_selection]: SDL left button up. The mouse button is already up, we missed an event.
20100815 15:56:28 debug gui/event: Firing: SDL left button up.
20100815 15:56:28 debug gui/event: distributor mouse button left [mp_method_selection]: SDL left button up.
20100815 15:56:28 warning gui/event: distributor mouse button left [mp_method_selection]: SDL left button up. The mouse button is already up, we missed an event.
20100815 15:56:28 debug gui/event: Firing: SDL mouse motion.
Comment 1 Bruno Wolff III 2010-08-15 19:15:20 EDT
This very likely a duplicate of 556608 which is fixed with SDL-1.2.14-7.
Comment 2 Rik van Riel 2010-08-15 20:03:43 EDT
Indeed, grabbing SDL-1.2.14-7.fc13.x86_64 from updates-testing seems to have fixed the issue.

Note You need to log in before you can comment on or make changes to this bug.