Bug 624347 - Failure installing to an LVM volume
Failure installing to an LVM volume
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-16 01:17 EDT by Máirín Duffy
Modified: 2010-08-17 19:15 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-16 16:44:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
traceback #1 (1.82 MB, text/plain)
2010-08-16 01:17 EDT, Máirín Duffy
no flags Details
traceback #2 (2.41 MB, text/plain)
2010-08-16 01:17 EDT, Máirín Duffy
no flags Details
traceback #3 (1.93 MB, text/plain)
2010-08-16 01:18 EDT, Máirín Duffy
no flags Details
device selection screen / screenshot (1.18 MB, image/png)
2010-08-16 01:19 EDT, Máirín Duffy
no flags Details
partition screen / screenshot (1.18 MB, image/png)
2010-08-16 01:19 EDT, Máirín Duffy
no flags Details
filesystem failure :( (1.16 MB, image/png)
2010-08-17 19:15 EDT, Máirín Duffy
no flags Details

  None (edit)
Description Máirín Duffy 2010-08-16 01:17:14 EDT
Created attachment 438889 [details]
traceback #1

Description of problem:

I have a desktop computer running Fedora 8. Time to upgrade. That system has two physical hard drives; one is roughly 320 GB, the other is 500 GB. Under Fedora 8, I combined them into one single logical volume group. I have a home volume, a root volume, and a swap volume, and then i also have a physical partition for /boot. Here's a little ascii art layout, although screenshot-2 shows it in the anaconda partition screen too:

> LVM Volume Group
  > PandaVolGroup (machine's hostname is panda)
    > HomeVol 305888 ext3
    > RootVol  20000 ext3
    > SwapVol   1504 ext3
    > Free    454560
> Hard Drives
  > sda
    > sda1    196 ext3
    > sda2 305046 PandaVolGroup LVM
  > sdb
    > sdb1 476940 PandaVolGroup LVM

I cooked up this scheme to make for easy upgrades. <= zomgbbq this sentence is hilarious!

I've got a liveusb key of the F13 final release. I booted it up, and clicked 'install to harddrive' to bring up anaconda. I do:

- Create Custom Layout.

- I select both physical hard drives as install target devices because I think separating the physical disks under the volume group would destroy the fabric of the space-time continuum.

Now about this time sometimes it doesn't even see the LVM Volume group. If I hit back and next again, it'll usually load them. But it's not consistent.

When it does see the LVM volume group, I try the following (and it usually tracebacks in here):

- Select 'RootVol' and delete it. Recreate it, same size, ext3 (although i tried ext4 too), name it RootVol, mount point /

- Select 'HomeVol' and attempt to mount it at /home. Usually this traces back. Sometimes if I resize it to a different value it doesn't traceback, but it's a little weird because it won't let me resize it over 200gb. It's weird because it's actually at 306GB right now and there should be 454GB free in the volgroup.

- Select sda1 and attempt to set it to /boot. it wants to be ext4, and when i hit okay it results in 2mb free space on sda which is weird, and there's no way to get rid of it.

I am terrified to actually click next, not that I was actually afforded the opportunity to (thanks tracebacks!) I am going to back up my home directory and potentially wipe it all and start over from scratch. 

However, this all still appears quite troubling to me - is this something you want to fix? Should I leave the machine in this state where it can easily reproduce these issues?

Version-Release number of selected component (if applicable):

anaconda-13.42-1.fc13.x86_64

How reproducible:
super-duperly so, but it seems to traceback in a slightly different spot each time

Steps to Reproduce:
See explanation above

Additional info:

I am attaching lots of screenshots and tracebacks.
Comment 1 Máirín Duffy 2010-08-16 01:17:52 EDT
Created attachment 438890 [details]
traceback #2
Comment 2 Máirín Duffy 2010-08-16 01:18:41 EDT
Created attachment 438891 [details]
traceback #3
Comment 3 Máirín Duffy 2010-08-16 01:19:16 EDT
Created attachment 438892 [details]
device selection screen / screenshot
Comment 4 Máirín Duffy 2010-08-16 01:19:43 EDT
Created attachment 438893 [details]
partition screen / screenshot
Comment 5 David Lehman 2010-08-16 12:23:53 EDT
The first two tracebacks are effectively the same as bug 580171, which wasn't fixed until after F13 was released. I think this bug is only triggered by re-editing a volume group (or logical volume) more than once, each time specifying resize of the same logical volume (HomeVol). In this case, potential workarounds include a) not resizing the logical volume or b) only editing it or PandaVolGroup once. I could provide you with an updates.img including the fix, but live installs make it difficult to use updates images. If you're feeling adventurous we can get you a patch that you can apply to the live root filesystem instead.

Having said all that, the simplest path through what I think you want to do is to just create filesystems without removing or adding any devices. Instead of deleting/recreating RootVol, just check the "Format as:" box, select either ext3 or ext4, then set the mountpoint to /. Likewise, instead of deleting sda1, just create a new filesystem on it by checking "Format as:", selecting ext4, and assigning /boot as the mountpoint.

The other traceback is completely unrelated to the others, and appears to have been fixed after F13 was released.

It isn't necessary for your to preserve the system for investigation -- we have a pretty good idea what's going on.
Comment 6 Máirín Duffy 2010-08-17 19:14:09 EDT
Thanks for the explanation Dave. I backed my data up and gave it a go. I noticed it is only possible to set more than one mount point under the logical volume group if you set the mount point for each volume in the group details dialog rathre than in the individual volume dialogs.

After quite some time anaconda decided my filesystem was corrupted and gave me the soon-to-be-attached scary error message. I guess I'll reinstall from 0. :)
Comment 7 Máirín Duffy 2010-08-17 19:15:13 EDT
Created attachment 439245 [details]
filesystem failure :(

Note You need to log in before you can comment on or make changes to this bug.