Bug 62455 - garnome-0.8.5 crashes (segfaults) on gtk+ compile
garnome-0.8.5 crashes (segfaults) on gtk+ compile
Status: CLOSED WORKSFORME
Product: Red Hat Raw Hide
Classification: Retired
Component: gcc (Show other bugs)
1.0
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-04-01 01:51 EST by Need Real Name
Modified: 2007-04-18 12:41 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-02 16:19:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Requested gtkmenuitem.i, compiled fine, no errors (573.76 KB, text/plain)
2002-04-03 15:44 EST, Need Real Name
no flags Details
Requested main.i, although not sure if compiled in the right directory, did get some errors, although produced main.i, unsure .. (849.28 KB, text/plain)
2002-04-03 15:46 EST, Need Real Name
no flags Details
gtkmenuitem.c: In function `gtk_menu_item_position_menu': gtkmenuitem.c:943: Internal error: Segmentation fault. Based on garnome-0.8.6 (573.76 KB, text/plain)
2002-04-06 23:36 EST, Need Real Name
no flags Details

  None (edit)
Description Need Real Name 2002-04-01 01:51:53 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.0 (X11; Linux i686; U;) Gecko/20020326

Description of problem:
Actually the version is mismatched, the versions are garnome-0.85 which I think
is gnome2 beta 3 and gtk+ that is trying to compile is gtk+-2.0.1, I think.

My version of gcc is gcc-2.96-98 and it is redhat stock kernel using
kernel-athlon 2.4.9-31custom with athlonxp 1.5 proc and 512 ram, gigabyte 7vtxe
motherboard.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.as test gnome user with normal priv, tar zxvf garnome-0.8.5.tar.gz then cd to
dir and 'make install'
2.exact error occurs on multiple tries, basically, in short: 
gtkmenuitem.c: In function `gtk_menu_item_position_menu':
gtkmenuitem.c:943: Internal error: Segmentation fault.
Please submit a full bug report.
See <URL:http://bugzilla.redhat.com/bugzilla/> for instructions.
make[11]: *** [gtkmenuitem.lo] Error 1
3.
	

Actual Results:  compilation segfaults

Expected Results:  run gnome2 as test user

Additional info:  i've been asked by developers and users of garnome if i'm
overclocking my cpu, which i'm not, however i've heard that athlon cpu's run
really hot, don't know if this applies to athlonxp though
Comment 1 Jakub Jelinek 2002-04-02 13:33:11 EST
I need full preprocessed source (gtkmenuitem.i created when you run gcc on
gtkmenuitem.c with the options gargnome passes to it and -save-temps), plus
the list of gcc options to reproduce this.
Comment 2 Need Real Name 2002-04-02 19:25:17 EST
[root@localhost root]# locate gtkmenuitem
/usr/include/gtk-1.2/gtk/gtkmenuitem.h
/home/gnome2_tester/garnome-0.8.5/gnome/gtk+/work/gtk+-2.0.1/gtk/gtkmenuitem.c
/home/gnome2_tester/garnome-0.8.5/gnome/gtk+/work/gtk+-2.0.1/gtk/gtkmenuitem.h
/home/gnome2_tester/garnome-0.8.5/gnome/gtk+/work/gtk+-2.0.1/gtk/gtkmenuitem.lo
/home/gnome2_tester/garnome-0.8.5/gnome/gtk+/work/gtk+-2.0.1/gtk/gtkmenuitem.o
/home/gnome2_tester/garnome-0.8.5/gnome/gtk+/work/gtk+-2.0.1/docs/tutorial/html/sec-gtkmenuitem.html
/home/gnome2_tester/garnome-0.8.5/gnome/gtk+/work/gtk+-2.0.1/docs/reference/gtk/tmpl/gtkmenuitem.sgml
/home/gnome2_tester/garnome-0.8.5/gnome/gtk+/work/gtk+-2.0.1/docs/reference/gtk/sgml/gtkmenuitem.sgml
/home/gnome2_tester/garnome-0.8.5/gnome/gtk+/work/gtk+-2.0.1/docs/reference/gtk/html/gtkmenuitem.htmlg

I only see gtkmenuitem.c, gtkmenuitem.h, gtkmenuitem.lo, gtkmenutiem.o. This is
after running 'make install' in
/home/gnome2_tester/garnome-0.8.5/meta/gnome-desktop  How can I reproduce
gtkmenuitem.i  I've tried 'make install -save-temps' to no avail.  There is only
a 'Makefile' in /home/gnome2_tester/garnome-0.8.5/meta/gnome-desktop/, no
autoconf or configure.

The only *.i I can find after running 'make install' of garnome-desktop is:

/home/gnome2_tester/garnome-0.8.5/gnome/pango/work/pango-1.0.1/pango/mini-fribidi/fribidi_tables.i
/home/gnome2_tester/garnome-0.8.5/gnome/pango/work/pango-1.0.1/modules/basic/tables-big.i
/home/gnome2_tester/garnome-0.8.5/gnome/pango/work/pango-1.0.1/modules/basic/tables-small.i
/home/gnome2_tester/garnome-0.8.5/gnome/pango/work/pango-1.0.1/modules/hangul/tables-ksc5601.i
/home/gnome2_tester/garnome-0.8.5/gnome/pango/work/pango-1.0.1/modules/hangul/tables-johabfont.i

Shall I try compiling and installing gtk-2.0.1 separately?

Also on latest compile and install try, I'm getting a different error:

gcc -DHAVE_CONFIG_H -I. -I. -I../..
-DDEMOCODEDIR="\"/home/gnome2_tester/garnome/share/gtk-2.0/demo\"" -I../..
-I../../gdk -DG_DISABLE_DEPRECATED -DGDK_DISABLE_DEPRECATED
-DGDK_PIXBUF_DISABLE_DEPRECATED -DGTK_DISABLE_DEPRECATED -DG_ENABLE_DEBUG
-D_REENTRANT -I/home/gnome2_tester/garnome/include/glib-2.0
-I/home/gnome2_tester/garnome/lib/glib-2.0/include
-I/home/gnome2_tester/garnome/include/pango-1.0 -I/usr/X11R6/include
-I/home/gnome2_tester/garnome/include
-I/home/gnome2_tester/garnome/include/freetype2
-I/home/gnome2_tester/garnome/include/atk-1.0 
-I/home/gnome2_tester/garnome/include -I/home/gnome2_tester/garnome/include
-I/home/gnome2_tester/garnome/include -I/home/gnome2_tester/garnome/include
-I/home/gnome2_tester/garnome/include -I/home/gnome2_tester/garnome/include
-I/home/gnome2_tester/garnome/include -I/home/gnome2_tester/garnome/include 
-I/home/gnome2_tester/garnome/include -g -O2
-I/home/gnome2_tester/garnome/include -g -O2
-I/home/gnome2_tester/garnome/include -g -O2
-I/home/gnome2_tester/garnome/include -g -O2
-I/home/gnome2_tester/garnome/include -g -O2
-I/home/gnome2_tester/garnome/include -g -O2
-I/home/gnome2_tester/garnome/include -g -O2
-I/home/gnome2_tester/garnome/include -g -O2 -Wall -c main.c
main.c: In function `load_file':
main.c:553: Internal error: Segmentation fault.
Please submit a full bug report.
See <URL:http://bugzilla.redhat.com/bugzilla/> for instructions.
make[11]: *** [main.o] Error 1
make[11]: Leaving directory
`/home/gnome2_tester/garnome-0.8.5/gnome/gtk+/work/gtk+-2.0.1/demos/gtk-demo'
make[10]: *** [all-recursive] Error 1
make[10]: Leaving directory
`/home/gnome2_tester/garnome-0.8.5/gnome/gtk+/work/gtk+-2.0.1/demos'
make[9]: *** [all-recursive] Error 1
make[9]: Leaving directory
`/home/gnome2_tester/garnome-0.8.5/gnome/gtk+/work/gtk+-2.0.1'
make[8]: *** [all-recursive-am] Error 2
make[8]: Leaving directory
`/home/gnome2_tester/garnome-0.8.5/gnome/gtk+/work/gtk+-2.0.1'
make[7]: *** [build-work/gtk+-2.0.1/Makefile] Error 2
make[7]: Leaving directory `/home/gnome2_tester/garnome-0.8.5/gnome/gtk+'
make[6]: *** [dep-../../gnome/gtk+] Error 2
make[6]: Leaving directory `/home/gnome2_tester/garnome-0.8.5/gnome/libglade'
make[5]: *** [dep-../../gnome/libglade] Error 2
make[5]: Leaving directory `/home/gnome2_tester/garnome-0.8.5/gnome/libgnomecanvas'
make[4]: *** [dep-../../gnome/libgnomecanvas] Error 2
make[4]: Leaving directory `/home/gnome2_tester/garnome-0.8.5/gnome/libbonoboui'
make[3]: *** [dep-../../gnome/libbonoboui] Error 2
make[3]: Leaving directory `/home/gnome2_tester/garnome-0.8.5/gnome/libgnomeui'
make[2]: *** [dep-../../gnome/libgnomeui] Error 2
make[2]: Leaving directory `/home/gnome2_tester/garnome-0.8.5/gnome/rep-gtk'
make[1]: *** [dep-../../gnome/rep-gtk] Error 2
make[1]: Leaving directory `/home/gnome2_tester/garnome-0.8.5/gnome/sawfish'
make: *** [dep-../../gnome/sawfish] Error 2

Let me know how to reproduce with options you need and I can provide more
information, i.e. how to reproduce gtkmenuitem.i and the like as well as where I
can find the gcc options I'm passing and where to '-save-temps'  (I'm assuming
this is how I will get gtkmenuitem.i, although with different error posted
above, I'm not sure if that's what you need, please let me know.
Comment 3 Jakub Jelinek 2002-04-03 04:31:34 EST
You need to cut'n'paste the gcc command line which is used to compile
gtkmenuitem.c into shell prompt, add -save-temps and run that, that way
you get gtkmenuitem.i. Similarly, above where you say it crashed compiling
main.c, you need to run
gcc -DHAVE_CONFIG_H -I. -I. -I../.. -DDEMOCODEDIR="\"/home/gnome2_tester/garnome/share/gtk-2.0/demo\"" -I../.. -DGDK_PIXBUF_DISABLE_DEPRECATED -DGTK_DISABLE_DEPRECATED -DG_ENABLE_DEBUG -D_REENTRANT -I/home/gnome2_tester/garnome/include/glib-2.0 -I/home/gnome2_tester/garnome/lib/glib-2.0/include -I/home/gnome2_tester/garnome/include/pango-1.0 -I/usr/X11R6/include -I/home/gnome2_tester/garnome/include -I/home/gnome2_tester/garnome/include/freetype2 -I/home/gnome2_tester/garnome/include/atk-1.0 -I/home/gnome2_tester/garnome/include -I/home/gnome2_tester/garnome/include -I/home/gnome2_tester/garnome/include -g -O2 -Wall -c main.c -save-temps
and provide main.i it creates (assuming it segfaults, if not, it would mean
a hardware issue).
Comment 4 Need Real Name 2002-04-03 15:44:32 EST
Created attachment 52104 [details]
Requested gtkmenuitem.i, compiled fine, no errors
Comment 5 Need Real Name 2002-04-03 15:46:27 EST
Created attachment 52105 [details]
Requested main.i, although not sure if compiled in the right directory, did get some errors, although produced main.i, unsure ..
Comment 6 Need Real Name 2002-04-06 23:36:05 EST
Created attachment 52584 [details]
gtkmenuitem.c: In function `gtk_menu_item_position_menu':
gtkmenuitem.c:943: Internal error: Segmentation fault. Based on garnome-0.8.6
Comment 7 Jakub Jelinek 2004-10-02 16:19:09 EDT
Compiles just fine with GCC 3.2.x or 3.4.x.
Comment 8 Need Real Name 2004-10-02 16:33:38 EDT
I think the problem was faulty hardware.  The mainboard I had at the
time was a low budget Gigabyte and had other issues with gcc as well.

Please change status to 'faulty hardware' if possible.

Note You need to log in before you can comment on or make changes to this bug.