Bug 62458 - KDM "Console Login" potentially confusing to return to KDM
KDM "Console Login" potentially confusing to return to KDM
Status: CLOSED WONTFIX
Product: Red Hat Public Beta
Classification: Retired
Component: kdebase (Show other bugs)
skipjack-beta1
All Linux
medium Severity medium
: ---
: ---
Assigned To: wdovlrrw
Ben Levenson
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-04-01 03:07 EST by Warren Togami
Modified: 2007-04-18 12:41 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-21 05:42:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Warren Togami 2002-04-01 03:07:50 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020314

Description of problem:
KDM has a new option next to "Restart X server" called "Console Login (Alt-N)".
 This is good because several users in my LUG didn't know about virtual
terminals and wanted to reach the console.

Unfortunately, this option does not give them any indicator of how to get back
into X when they are done at the console.  X is completely killed and the only
way they can get back to KDM is "init 3; init 5"

kdm still running in the background at this point.  Not very clean...

I propose adding an informational dialogue when users select "Console Login" at
the KDM screen.  The option shouldn't kill X at all, instead simply tell them to
hit CTRL-ALT-F1, and CTRL-ALT-F7 to get back to X.  I would prefer this to
killing X because it is more elegant, and educating the user about the "Right way".

Does anyone agree?  Does anyone see any drawbacks to this approach?

Would Red Hat acccept a patch to KDM to implement this?  If so, then I'd like to
work on coding this.  Please let me know.
Comment 1 Bernhard Rosenkraenzer 2002-04-01 04:23:37 EST
We can't add another dialog at this time because it would break translations.
A message educating someone about virtual terminals in English is useless to
someone who doesn't understand the language.

Also, hardcoding CTRL-ALT-F7 is a bad idea; many people change their inittab to
get X on a different VT (e.g. I use 11 textmode terminals and X in the 12th),
others tail -f /var/log/messages >/dev/tty7 and get X on 8 etc.

A dialog informing the user about returning to X would make sense in any case.
I'd suggest something along the lines of

'This will kill your X session. If you just want to access a virtual terminal
without killing X, press CTRL-ALT-F1 and CTRL-ALT-Whatever to return to X.
If you really want to kill X, you can return by typing "init 5".'

Please resend your request to http://bugs.kde.org/, that's the only way to get
it into base CVS (which in turn is the only way to get any mmessages translated).

Comment 2 Bernhard Rosenkraenzer 2002-04-01 04:24:28 EST
Closing WONTFIX for now because of the translation issue, this doesn't mean it
won't ever happen.
Comment 3 Warren Togami 2002-04-01 04:39:04 EST
> 'This will kill your X session. If you just want to 
> access a virtual terminal without killing X, press 
> CTRL-ALT-F1 and CTRL-ALT-Whatever to return to X.
> If you really want to kill X, you can return by 
> typing "init 5".'

I was thinking about parsing inittab to find the X VT, but I now realize there 
might be cases where that may be problematic.  Can you think of any such 
cases?  I can't at the moment.

I will work on this, what deadline do I have to get this into KDE CVS to be 
included in Red Hat final?
Comment 4 Bernhard Rosenkraenzer 2002-04-01 04:44:00 EST
There is no way to get it in the final of the next version.
KDE 3.0 has been released (so far to packagers only), so we won't
update to CVS snapshots anymore.

I'm expecting KDE 3.1 in time for the release beyond this one,
though - so if you can get it in by then, it'll be in 7.4/8.0/Linux XP
or whatever the release will be called.
Comment 5 Warren Togami 2002-04-21 05:42:40 EDT
I just had an idea.

Why doesn't it use chvt rather than killing X permanently?  This seems proper.

If this is too late I understand.

Note You need to log in before you can comment on or make changes to this bug.