Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 624602 - rmmod igb panics the kernel at intel-sunriseridge-01.lab.bos.redhat.com
rmmod igb panics the kernel at intel-sunriseridge-01.lab.bos.redhat.com
Status: CLOSED DUPLICATE of bug 606687
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kernel (Show other bugs)
6.0
All Linux
high Severity high
: rc
: ---
Assigned To: Stefan Assmann
Red Hat Kernel QE team
: RHELNAK
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-17 04:14 EDT by Xiao jing Fang
Modified: 2010-08-22 14:14 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-22 14:14:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Xiao jing Fang 2010-08-17 04:14:35 EDT
Description of problem:
rmmod igb panics the kernel

Version-Release number of selected component (if applicable):


How reproducible:
make sure eth num > 1

Steps to Reproduce:
1.config /etc/sysconfig/network-script/ifcfg-eth%d
2.ifup eth%d
3.rmmod igb
  
Actual results:
kernel panics and reboot,the message:
RIP !INEXACT! 10:<ffffffff8101bbe1> {mwait_idle+0x71/0xd0}
TSC b8d54e3f30 MISC 2 
PROCESSOR 0:206e6 TIME 1282015986 SOCKET 0 APIC 2
No human readable MCE decoding support on this CPU type.
Run the message through 'mcelog --ascii' to decode.
CPU 0: Machine Check Exception:                5 Bank 0: fa00000000400e0f
RIP !INEXACT! 10:<ffffffff8101bbe1> {mwait_idle+0x71/0xd0}
TSC b8d54e2366 MISC 1 
PROCESSOR 0:206e6 TIME 1282015986 SOCKET 0 APIC 0
No human readable MCE decoding support on this CPU type.
Run the message through 'mcelog --ascii' to decode.
This is not a software problem!
Machine check: Processor context corrupt
Kernel panic - not syncing: Fatal Machine check
Pid: 0, comm: swapper Tainted: G   M       2.6.32-44.el6.x86_64 #1
Call Trace:
 <#MC>  [<ffffffff814d7823>] panic+0x78/0x137
 [<ffffffff81027322>] mce_panic+0x1e2/0x210
 [<ffffffff810289f8>] do_machine_check+0xa28/0xa70
 [<ffffffff8101bbe1>] ? mwait_idle+0x71/0xd0
 [<ffffffff814dac6c>] machine_check+0x1c/0x30
 [<ffffffff8101bbe1>] ? mwait_idle+0x71/0xd0
 <<EOE>>  [<ffffffff81011e96>] cpu_idle+0xb6/0x110
 [<ffffffff814d1331>] start_secondary+0x1fc/0x23f



Expected results:
netdriver removed

Additional info:
Comment 1 RHEL Product and Program Management 2010-08-17 04:18:33 EDT
This issue has been proposed when we are only considering blocker
issues in the current Red Hat Enterprise Linux release.

** If you would still like this issue considered for the current
release, ask your support representative to file as a blocker on
your behalf. Otherwise ask that it be considered for the next
Red Hat Enterprise Linux release. **
Comment 2 Prarit Bhargava 2010-08-20 10:06:33 EDT
mce while rmmod'ing?

P.
Comment 3 Stefan Assmann 2010-08-20 11:16:55 EDT
which kernel version?
Comment 4 Stefan Assmann 2010-08-22 14:14:35 EDT
never mind I found it: 2.6.32-44
Already fixed in -52.

Reopen if you can reproduce it with a more recent kernel.

*** This bug has been marked as a duplicate of bug 606687 ***

Note You need to log in before you can comment on or make changes to this bug.