Bug 62463 - konsole: Home/End/Del keys don't work if set bell-style visible is set in inputrc
Summary: konsole: Home/End/Del keys don't work if set bell-style visible is set in inp...
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: bash   
(Show other bugs)
Version: 7.3
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: wdovlrrw
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-04-01 11:52 UTC by Gerald Teschl
Modified: 2007-04-18 16:41 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-03 11:59:13 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Gerald Teschl 2002-04-01 11:52:21 UTC
kdebase-3.0.0-0.cvs20020314.4

Subject says it all. Home does nothing. End,Del produces a "~"

Comment 1 Bernhard Rosenkraenzer 2002-04-02 11:21:35 UTC
Works for me. Must be a settings problem.

Comment 2 Gerald Teschl 2002-04-02 18:24:16 UTC
It does not work if your ~/.inputrc contains "set bell-style visible"

Comment 3 Bernhard Rosenkraenzer 2002-04-03 11:59:08 UTC
Updating description

Comment 4 Bernhard Rosenkraenzer 2002-04-03 12:09:32 UTC
This is not specific to konsole.  
Setting bell-style visible breaks all of the following:  
- Del key in text mode  
- End and Del keys in xterm  
- End and Del keys in gnome-terminal  
- Home, End and Del keys in konsole  
  
  
Cause: 
If you have a .inputrc, /etc/inputrc isn't read anymore, therefore you don't get the  
correct key codes. 
 
Fix: 
cp /etc/inputrc .inputrc 
echo "set bell-style visible" >>.inputrc 



Note You need to log in before you can comment on or make changes to this bug.