Bug 624795 - gnome desktop is displaying nfs automounts(from NetApp snaphots) as removeable media
Summary: gnome desktop is displaying nfs automounts(from NetApp snaphots) as removeabl...
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: gvfs (Show other bugs)
(Show other bugs)
Version: 6.0
Hardware: All Linux
high
high
Target Milestone: rc
: ---
Assignee: Tomáš Bžatek
QA Contact: desktop-bugs@redhat.com
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks: 648498
TreeView+ depends on / blocked
 
Reported: 2010-08-17 19:38 UTC by Scott Spurrier
Modified: 2018-11-14 18:41 UTC (History)
8 users (show)

Fixed In Version: gvfs-1.4.3-10.el6
Doc Type: Enhancement
Doc Text:
Cause: Exports located on Network Appliance filers mounted via NFS contain snapshot directories Consequence: These mounts were shown in the UI leading to user confusion Fix: A check has been placed and we now hide mounts whose are in the path which element starts with a dot Result: No snapshot directories mounts are shown in GUI
Story Points: ---
Clone Of:
: 648498 (view as bug list)
Environment:
Last Closed: 2011-05-19 13:02:54 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
gvfs-1.4.3-hide-dot-mounts.patch (724 bytes, patch)
2010-08-27 15:10 UTC, Tomáš Bžatek
no flags Details | Diff
glib-2.22.5-gio-hide-dot-mounts.patch (613 bytes, patch)
2010-08-27 15:11 UTC, Tomáš Bžatek
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:0536 normal SHIPPED_LIVE gvfs bug fix and enhancement update 2011-05-18 17:57:41 UTC

Description Scott Spurrier 2010-08-17 19:38:42 UTC
Description of problem:

We use NFS mounted home directories located on Network Appliance filers which support snapshotting. The snapshots are kept under a hidden .snapshot directory. If a user traverses into the .snapshot directory under ~/Desktop, the gnome desktop will suddenly display every available snapshot (typically 24 directories for the past 24 hours and 3 or 4 nightly directories). The desktop is treating these directories as if they were removable media just inserted. It's not possible to unmount these or delete them from the Desktop. Logging out and back in doesn't clear them. You have to wait hours for the mounts to time out before they disappear.

How can we prevent the Desktop from displaying these directories? Since they are subdirectories of ~/Desktop/.snapshot, why are they even showing up?


How reproducible:
Always

Steps to Reproduce:
1. open a shell and cd to ~/Desktop on a NetApp nfs home directory with snapshots enabled.
2. cd .snapshot; ls
3. Notice all the snapshot directories on the Desktop

Additional info:

This problem doesn't happen on RHEL5.

Comment 3 RHEL Product and Program Management 2010-08-17 19:58:11 UTC
This issue has been proposed when we are only considering blocker
issues in the current Red Hat Enterprise Linux release.

** If you would still like this issue considered for the current
release, ask your support representative to file as a blocker on
your behalf. Otherwise ask that it be considered for the next
Red Hat Enterprise Linux release. **

Comment 4 Tomáš Bžatek 2010-08-18 08:58:54 UTC
Could you please attach output of the `mount` and `udisks --dump` commands?

Comment 6 RHEL Product and Program Management 2010-08-18 21:32:49 UTC
Thank you for your bug report. This issue was evaluated for inclusion
in the current release of Red Hat Enterprise Linux. Unfortunately, we
are unable to address this request in the current release. Because we
are in the final stage of Red Hat Enterprise Linux 6 development, only
significant, release-blocking issues involving serious regressions and
data corruption can be considered.

If you believe this issue meets the release blocking criteria as
defined and communicated to you by your Red Hat Support representative,
please ask your representative to file this issue as a blocker for the
current release. Otherwise, ask that it be evaluated for inclusion in
the next minor release of Red Hat Enterprise Linux.

Comment 7 Tomáš Bžatek 2010-08-25 12:58:47 UTC
Interesting and also strange enough. I couldn't see any suspicious mounts belonging to snapshots. Usually we show mounts from fstab (filtered by some criteria), abandoned/unowned physical devices, active mounts and GVfs stuff. Do mtab or /proc/mounts show these records?

Can you also attach output of `gvfs-ls -lh computer://` when the extra mounts are shown and do `gvfs-info computer:///<mount_name>` on one of them? Or, is this easily reproducible on a local machine?

Comment 10 Tomáš Bžatek 2010-08-27 15:10:27 UTC
Created attachment 441536 [details]
gvfs-1.4.3-hide-dot-mounts.patch

After little chat with David yesterday we agreed to hide mounts where the mountpoint path element starts with a dot (i.e. hide /media/.shared and also /media/.subdir/shared).

Comment 11 Tomáš Bžatek 2010-08-27 15:11:32 UTC
Created attachment 441537 [details]
glib-2.22.5-gio-hide-dot-mounts.patch

Glib2 must be patched too along with gvfs.

Comment 20 Tomáš Bžatek 2011-04-11 16:00:32 UTC
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Cause: Exports located on Network Appliance filers mounted via NFS contain snapshot directories

Consequence: These mounts were shown in the UI leading to user confusion

Fix: A check has been placed and we now hide mounts whose are in the path which element starts with a dot

Result: No snapshot directories mounts are shown in GUI

Comment 21 errata-xmlrpc 2011-05-19 13:02:54 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-0536.html


Note You need to log in before you can comment on or make changes to this bug.