Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 624826 - rhel6 boot_from_san cannot boot after new initramfs
rhel6 boot_from_san cannot boot after new initramfs
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: dracut (Show other bugs)
6.0
All Linux
urgent Severity urgent
: rc
: ---
Assigned To: Harald Hoyer
Release Test Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-17 16:59 EDT by Anthony Cheung
Modified: 2015-09-16 19:46 EDT (History)
23 users (show)

See Also:
Fixed In Version: dracut-004-32.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-10 15:19:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
some files and output catpured (10.00 KB, application/x-tar)
2010-08-17 18:13 EDT, Anthony Cheung
no flags Details
screen capture when server cannot boot (63.70 KB, image/jpeg)
2010-08-17 18:14 EDT, Anthony Cheung
no flags Details
original created during OS installation (13.37 MB, application/octet-stream)
2010-08-27 13:10 EDT, Anthony Cheung
no flags Details
new one created afterward (13.21 MB, application/octet-stream)
2010-08-27 13:14 EDT, Anthony Cheung
no flags Details

  None (edit)
Description Anthony Cheung 2010-08-17 16:59:48 EDT
Description of problem:
Rhel6 snapshot8 was installed to SAN array lun with 2 paths.  Server booted up fine after installation completed.  However, after making a new initramfs and adding new entry in menu.lst, it failed to boot using the new initramfs

Notice the new initramfs file size is more than 50% smaller than original initramfs created by installation.  The new initramfs was made without any other change to the server.

Some attachements to follow.

Version-Release number of selected component (if applicable):


How reproducible:
Always


Steps to Reproduce:
1. make new initramfs after installation
2. add new entry in menu.lst to use the new initramfs
3. reboot server
  
Actual results:


Expected results:


Additional info:
Comment 2 RHEL Product and Program Management 2010-08-17 17:18:12 EDT
This issue has been proposed when we are only considering blocker
issues in the current Red Hat Enterprise Linux release.

** If you would still like this issue considered for the current
release, ask your support representative to file as a blocker on
your behalf. Otherwise ask that it be considered for the next
Red Hat Enterprise Linux release. **
Comment 3 Bill Nottingham 2010-08-17 17:20:45 EDT
Can you try with a later snapshot?
Comment 4 Anthony Cheung 2010-08-17 18:13:37 EDT
Created attachment 439230 [details]
some files and output catpured

some files and output catpured when the server is able to boot back up using original initramfs
Comment 5 Anthony Cheung 2010-08-17 18:14:54 EDT
Created attachment 439232 [details]
screen capture when server cannot boot
Comment 6 Anthony Cheung 2010-08-17 18:16:45 EDT
I will try with snaphot10
Comment 7 Tom Coughlan 2010-08-18 12:04:40 EDT
It is probably best for the Dracut folks to look at this, if it persists in Snapshot 10. 

I note, btw, that the screen capture in comment 5 mentions "sdc", but that device is not in the lsscsi output included in comment 4. ?
Comment 8 Tom Coughlan 2010-08-18 12:12:04 EDT
(In reply to comment #7)

> I note, btw, that the screen capture in comment 5 mentions "sdc", but that
> device is not in the lsscsi output included in comment 4. ?

Nevermind that. Sorry, I misread it. It is sda3 in the screen capture.
Comment 9 Harald Hoyer 2010-08-18 12:23:12 EDT
(In reply to comment #0)
> Description of problem:
> Rhel6 snapshot8 was installed to SAN array lun with 2 paths.  Server booted up
> fine after installation completed.  However, after making a new initramfs and
> adding new entry in menu.lst, it failed to boot using the new initramfs
> 
> Notice the new initramfs file size is more than 50% smaller than original
> initramfs created by installation.  The new initramfs was made without any
> other change to the server.

how did you create the initramfs?
Comment 10 Anthony Cheung 2010-08-18 12:35:06 EDT
mkinitrd initramfs<newname> 2.6.32-52.el6.x86_64

Is there a new command?
Comment 11 Anthony Cheung 2010-08-18 20:08:12 EDT
Tried to experiment with snapshot10 but it can't even install.  New Bug 625250 filed against snapshot10.  In the meantime, can any troubleshooting be done with snapshot8?
Comment 12 Harald Hoyer 2010-08-19 05:36:03 EDT
(In reply to comment #10)
> mkinitrd initramfs<newname> 2.6.32-52.el6.x86_64
> 
> Is there a new command?

Yes, dracut generates now the images.

# dracut /boot/initramfs-<kernel version>.img <kernel version>

but, this should have been invoked by your

# mkinitrd /boot/initramfs-<kernel version>.img <kernel version>

anyway, show me the file sizes please
Comment 13 Harald Hoyer 2010-08-19 05:37:19 EDT
(In reply to comment #5)
> Created attachment 439232 [details]
> screen capture when server cannot boot

This looks like the multipath bug. Is this a multipath install?
Comment 14 Harald Hoyer 2010-08-19 05:40:44 EDT
(In reply to comment #13)
> (In reply to comment #5)
> > Created attachment 439232 [details] [details]
> > screen capture when server cannot boot
> 
> This looks like the multipath bug. Is this a multipath install?

ok, saw the multipath.conf in the working case. please change /lib/udev/rules.d/40-multipath.rules with the file from:

https://bugzilla.redhat.com/show_bug.cgi?id=595719#c16

and regenerate the initramfs image with:

# dracut -f /boot/initramfs-<kernel version>.img <kernel version>
Comment 15 Anthony Cheung 2010-08-19 11:59:24 EDT
Tried dracut command and WITHOUT 40-multipath.rules change, and the server boots up fine with the new initramfs.

But I will incorporate the new 40-multipath.rules anyway and continue testing.

There is definitely file size difference of initramfs created by dracut and mkinitrd

[root@lnx-srv23 boot]# dracut -f initramfs-2.6.32-52.el6.x86_64-3.img 2.6.32-52.el6.x86_64
[root@lnx-srv23 boot]# ll -rt
total 43805
-rw-r--r--. 1 root root  2220287 Jul 21 09:25 System.map-2.6.32-52.el6.x86_64
-rw-r--r--. 1 root root    97904 Jul 21 09:25 config-2.6.32-52.el6.x86_64
-rwxr-xr-x. 1 root root  3811712 Jul 21 09:25 vmlinuz-2.6.32-52.el6.x86_64
-rw-r--r--. 1 root root   161201 Jul 21 09:27 symvers-2.6.32-52.el6.x86_64.gz
drwx------. 2 root root    12288 Aug 12 15:30 lost+found
drwxr-xr-x. 3 root root     1024 Aug 12 15:52 efi
-rw-r--r--. 1 root root 14006734 Aug 12 15:54 initramfs-2.6.32-52.el6.x86_64.img
-rw-r--r--. 1 root root  4493357 Aug 12 15:57 initrd-2.6.32-52.el6.x86_64kdump.img
-rw-r--r--  1 root root  5787128 Aug 16 08:46 initramfs-2.6.32-52.el6.x86_64-2.img
drwxr-xr-x. 2 root root     1024 Aug 17 09:20 grub
-rw-r--r--  1 root root 14064031 Aug 19 08:05 initramfs-2.6.32-52.el6.x86_64-3.img
[root@lnx-srv23 boot]# mkinitrd -f initramfs-2.6.32-52.el6.x86_64-4.img 2.6.32-52.el6.x86_64
[root@lnx-srv23 boot]# ll -rt
total 49480
-rw-r--r--. 1 root root  2220287 Jul 21 09:25 System.map-2.6.32-52.el6.x86_64
-rw-r--r--. 1 root root    97904 Jul 21 09:25 config-2.6.32-52.el6.x86_64
-rwxr-xr-x. 1 root root  3811712 Jul 21 09:25 vmlinuz-2.6.32-52.el6.x86_64
-rw-r--r--. 1 root root   161201 Jul 21 09:27 symvers-2.6.32-52.el6.x86_64.gz
drwx------. 2 root root    12288 Aug 12 15:30 lost+found
drwxr-xr-x. 3 root root     1024 Aug 12 15:52 efi
-rw-r--r--. 1 root root 14006734 Aug 12 15:54 initramfs-2.6.32-52.el6.x86_64.img
-rw-r--r--. 1 root root  4493357 Aug 12 15:57 initrd-2.6.32-52.el6.x86_64kdump.img
-rw-r--r--  1 root root  5787128 Aug 16 08:46 initramfs-2.6.32-52.el6.x86_64-2.img
drwxr-xr-x. 2 root root     1024 Aug 17 09:20 grub
-rw-r--r--  1 root root 14064031 Aug 19 08:05 initramfs-2.6.32-52.el6.x86_64-3.img
-rw-r--r--  1 root root  5786467 Aug 19 08:06 initramfs-2.6.32-52.el6.x86_64-4.img
[root@lnx-srv23 boot]#
Comment 16 Harald Hoyer 2010-08-19 12:09:59 EDT
Ok, so the "hostonly" mode of dracut, which is used with the "mkinitrd" shell wrapper, does not work in your case.

I should really remove the "-H" option for dracut in mkinitrd!!!
Comment 17 Phil Knirsch 2010-08-19 12:17:23 EDT
Very easy fix and potentially bad for customers who use (and are used to) using mkinitrd instead of dracut to recreate the initramfs. Granted Devel ACK and proposed blocker for Snap 13.

Thanks & regards, Phil
Comment 18 Harald Hoyer 2010-08-19 14:51:00 EDT
dracut-004-32.el6
Comment 20 Anthony Cheung 2010-08-27 13:10:13 EDT
Created attachment 441574 [details]
original created during OS installation
Comment 21 Anthony Cheung 2010-08-27 13:14:02 EDT
Created attachment 441575 [details]
new one created afterward

This is a new initramfs after commented out multipath{} braces in original multipath.conf just for experiment
Comment 22 Anthony Cheung 2010-08-27 17:36:46 EDT
Comment on attachment 441574 [details]
original created during OS installation

sorry attached to wrong bug
Comment 23 Anthony Cheung 2010-08-27 17:37:14 EDT
Comment on attachment 441575 [details]
new one created afterward

sorry attached to wrong bug
Comment 24 michal novacek 2010-08-30 04:20:36 EDT
Verified that the new dracut-004-32.el6 correctly removes the "-H" paramater from /sbin/mkinitrd script:

# rpm -qpV dracut-004-31.el6.noarch.rpm | grep "5\.\."
S.5....T.    /sbin/mkinitrd
..5....T.    /usr/share/dracut/modules.d/10rpmversion/dracut-version

# diff /sbin/mkinitrd /tmp/mkinitrd 
145c145
< 	dracut $dracut_args --add-drivers "$basicmodules" "$target" "$kernel"
---
> 	dracut -H $dracut_args --add-drivers "$basicmodules" "$target" "$kernel"
147c147
< 	dracut $dracut_args "$target" "$kernel"
---
> 	dracut -H $dracut_args "$target" "$kernel"

and creates correct (size) initramfs file that is bootable.
# ls -l /boot/initramfs-2.6.32-67.el6.x86_64.img*
-rw-r--r--. 1 root root 13664324 Aug 26 13:37 /boot/initramfs-2.6.32-67.el6.x86_64.img  < original
-rw-r--r--. 1 root root 13724838 Aug 30 04:08 /boot/initramfs-2.6.32-67.el6.x86_64.img4 < good
-rw-r--r--. 1 root root  6269473 Aug 30 03:47 /boot/initramfs-2.6.32-67.el6.x86_64.img8 < bad
Comment 26 releng-rhel@redhat.com 2010-11-10 15:19:49 EST
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.