Bug 624830 - Virtual Terminal login with smartcard: Should throw useful error message when userid mis-matches
Summary: Virtual Terminal login with smartcard: Should throw useful error message when...
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: pam_pkcs11   
(Show other bugs)
Version: 6.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Bob Relyea
QA Contact: Chandrasekar Kannan
URL:
Whiteboard:
Keywords: RHELNAK
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-08-17 21:09 UTC by Asha Akkiangady
Modified: 2015-01-04 23:43 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-22 23:15:05 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Asha Akkiangady 2010-08-17 21:09:55 UTC
Description of problem:
Virtual Terminal login with smartcard: Should throw useful error message when userid mis-matches. 

Version-Release number of selected component (if applicable):
[tester@dhcp231-173 ~]$ rpm -q authconfig pam_pkcs11 gdm
authconfig-6.1.4-6.el6.i686
pam_pkcs11-0.6.2-10.el6.i686
gdm-2.30.4-21.el6.i686

How reproducible:
Always

Steps to Reproduce:
1. Authentication is configured as:
Use smart card: ON Enforce smart card: ON Log out behaviour configured to:
Activate screen saver. 

2. A smart card is enrolled for this user.

3. Remove smart card from the hook and restart the desktop.

4. User logs in using the tty virtual terminal screen e.g. <ctrl> + <alt> +
<F2>. User types something random at the login prompt. 
5. The user is prompted for their smart card pin. Type correct pin.


Actual results:

"ERROR: pam_pkcs11.c:537: no valid certificate which meets all requirements found, Login incorrect." and Login prompt is re-displayed.

Expected results:

Should filter out this error message and add something more useful.

Additional info:

Comment 2 RHEL Product and Program Management 2010-08-17 21:38:27 UTC
This issue has been proposed when we are only considering blocker
issues in the current Red Hat Enterprise Linux release.

** If you would still like this issue considered for the current
release, ask your support representative to file as a blocker on
your behalf. Otherwise ask that it be considered for the next
Red Hat Enterprise Linux release. **

Comment 3 RHEL Product and Program Management 2010-08-18 21:31:12 UTC
Thank you for your bug report. This issue was evaluated for inclusion
in the current release of Red Hat Enterprise Linux. Unfortunately, we
are unable to address this request in the current release. Because we
are in the final stage of Red Hat Enterprise Linux 6 development, only
significant, release-blocking issues involving serious regressions and
data corruption can be considered.

If you believe this issue meets the release blocking criteria as
defined and communicated to you by your Red Hat Support representative,
please ask your representative to file this issue as a blocker for the
current release. Otherwise, ask that it be evaluated for inclusion in
the next minor release of Red Hat Enterprise Linux.

Comment 4 Bob Relyea 2010-11-22 23:12:44 UTC
If we waant this one I can reprioritize other bugs.

Comment 5 RHEL Product and Program Management 2010-11-22 23:15:05 UTC
Development Management has reviewed and declined this request.  You may appeal
this decision by reopening this request.


Note You need to log in before you can comment on or make changes to this bug.