Bug 624943 - quickly killing condor_configd running in debugging mode
quickly killing condor_configd running in debugging mode
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: condor-wallaby-client (Show other bugs)
1.3
All Linux
low Severity low
: 1.3.2
: ---
Assigned To: Robert Rati
Lubos Trilety
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-18 04:10 EDT by Lubos Trilety
Modified: 2011-02-15 08:02 EST (History)
1 user (show)

See Also:
Fixed In Version: condor-wallaby-client-3.6-6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-02-15 08:02:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lubos Trilety 2010-08-18 04:10:58 EDT
Description of problem:
When configd running in debugging mode is killed quickly after it's started, the exception appears.

Version-Release number of selected component (if applicable):
condor-wallaby-client-3.4-1

How reproducible:
100%

Steps to Reproduce:
1. Terminal one, start configd with '-d' option
$ _CONDOR_QMF_BROKER_HOST=localhost _CONDOR_QMF_CONFIGD_LOG=configd.log /usr/sbin/condor_configd -d

2. Terminal two run
$ killall -v condor_configd

  
Actual results:
Notice exception in terminal one
Traceback (most recent call last):
  File "/usr/lib64/python2.4/logging/handlers.py", line 71, in emit
    if self.shouldRollover(record):
  File "/usr/lib64/python2.4/logging/handlers.py", line 150, in shouldRollover
    self.stream.seek(0, 2)  #due to non-posix-compliant Windows feature
ValueError: I/O operation on closed file
Traceback (most recent call last):
  File "/usr/lib64/python2.4/logging/handlers.py", line 71, in emit
    if self.shouldRollover(record):
  File "/usr/lib64/python2.4/logging/handlers.py", line 150, in shouldRollover
    self.stream.seek(0, 2)  #due to non-posix-compliant Windows feature
ValueError: I/O operation on closed file


Expected results:
No exception
Comment 1 Robert Rati 2010-11-03 09:16:23 EDT
Unable to reproduce in the 3.6 build shipping with 1.3.  I believe this has been resolved already.
Comment 2 Lubos Trilety 2010-11-03 11:05:33 EDT
Tested with condor-wallaby-client-3.6-6, run 100 times without the exception.

Tested on:
RHEL5 x86_64,i386  - passed
RHEL4 x86_64,i386  - passed

>>> VERIFIED

Note You need to log in before you can comment on or make changes to this bug.