Bug 624965 - Can't add extra arguments to dhcrelay daemon
Can't add extra arguments to dhcrelay daemon
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: dhcp (Show other bugs)
5.7
All Linux
low Severity low
: rc
: ---
Assigned To: Jiri Popelka
Release Test Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-18 05:03 EDT by Bart Dopheide
Modified: 2011-07-21 06:58 EDT (History)
3 users (show)

See Also:
Fixed In Version: dhcp-3.0.5-27.el5
Doc Type: Bug Fix
Doc Text:
Previously, it was impossible to configure the dhcrelay service to run the dhcrelay daemon with additional arguments. With this update, a DHCRELAYARGS variable is available for the /etc/sysconfig/dhcrelay configuration file, which allows additional arguments to be passed to the dhcrelay daemon properly.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-07-21 06:58:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bart Dopheide 2010-08-18 05:03:53 EDT
Description of problem:
In our network, we have to use the -a option for the dhcrelay daemon. Currently, I see no 'clean' way to achieve this: only the variables INTERFACES and DHCPSERVERS can be changed.

Version-Release number of selected component (if applicable):
dhcp-3.0.5-23.el5_5.1

How reproducible:
Always

Steps to Reproduce:
1. Try to add -a somewhere to /etc/sysconfig/dhcrelay, but you fail to do so.
  
Actual results:
dhcrelay agent running without -a

Expected results:
dhcrelay agent running with -a

Additional info:
As a workaround, we add '-a' sneakely to variable DHCPSERVERS in /etc/sysconfig/dhcrelay, for instance
  DHCPSERVERS="-a 10.120.3.250"

Other initscripts use a configurable variables for this situation: DHCPDARGS (dhcpd), SYSLOGD_OPTIONS (syslog), EXTRAOPTIONS (xinetd). That is my suggestion to fix this bug.
Comment 1 Jiri Popelka 2010-08-20 08:04:42 EDT
Variable EXTRAOPTIONS (for other options than -i) sounds good to me.
Comment 2 RHEL Product and Program Management 2011-01-11 15:35:08 EST
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 3 RHEL Product and Program Management 2011-01-11 17:28:21 EST
This request was erroneously denied for the current release of
Red Hat Enterprise Linux.  The error has been fixed and this
request has been re-proposed for the current release.
Comment 7 Alexander Todorov 2011-05-27 09:47:34 EDT
in dhcp-3.0.5-29 there is 
DHCRELAYARGS variable in /etc/sysconfig/dhcrelay. When adding arguments to it they are passed to the dhcrelay daemon.
Comment 8 Tomas Capek 2011-05-31 04:20:32 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Previously, it was impossible to configure the dhcrelay service to run the dhcrelay daemon with additional arguments. With this update, a DHCRELAYARGS variable is available for the /etc/sysconfig/dhcrelay configuration file, which allows additional arguments to be passed to the dhcrelay daemon properly.
Comment 9 errata-xmlrpc 2011-07-21 06:58:50 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-1038.html

Note You need to log in before you can comment on or make changes to this bug.