Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 625109 - Reports from setroubleshoot and anaconda using report library gives bad product name, reporting to GSS not working
Reports from setroubleshoot and anaconda using report library gives bad produ...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: report (Show other bugs)
6.0
All Linux
urgent Severity urgent
: rc
: ---
Assigned To: Gavin Romig-Koch
David Kutálek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-18 11:53 EDT by David Kutálek
Modified: 2010-11-10 16:29 EST (History)
2 users (show)

See Also:
Fixed In Version: report-0.18-7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-10 16:29:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
generated xml report file (3.40 KB, text/xml)
2010-08-18 11:53 EDT, David Kutálek
no flags Details
Server complains about the product (286.50 KB, image/png)
2010-08-18 11:54 EDT, David Kutálek
no flags Details
Server complains about the product - from within Anaconda (49.97 KB, image/png)
2010-08-19 04:59 EDT, David Kutálek
no flags Details
Fixes this bz (2.01 KB, patch)
2010-08-20 20:55 EDT, Gavin Romig-Koch
no flags Details | Diff

  None (edit)
Description David Kutálek 2010-08-18 11:53:35 EDT
Created attachment 439418 [details]
generated xml report file

Description of problem:

XML report file from setroubleshoot is attached.
Product is just 'Redhat' instead of 'Red Hat Enterprise Linux'.

It means that GSS/Avalon/Strata server does not accept such report right now.
It means customers won't be able to report selinux problems to GSS.
We need to fix this in report, or possibly implement workaround in GSS servers.

Version-Release number of selected component (if applicable):

report-0.18-6.el6.x86_64

How reproducible:

Always.

Steps to Reproduce:
1. Create AVC message eg. using 'runcon -u system_u -r object_r -t httpd_t /bin/bash'
2. run 'sealert -b' hit report button and save to local file
3. inspect the file, namely product binding part
  
Actual results:

Product set to 'Redhat'

Expected results:

Product set to 'Red Hat Enterprise Linux'

Additional info:

Product is badly inserted also when trying to upload xml file without product binding using report command.
Comment 1 David Kutálek 2010-08-18 11:54:29 EDT
Created attachment 439419 [details]
Server complains about the product
Comment 2 David Kutálek 2010-08-19 04:59:16 EDT
Created attachment 439622 [details]
Server complains about the product - from within Anaconda

'Redhat is not a valid product' sounds horribly. We should definitely fix it.
Comment 3 David Kutálek 2010-08-19 05:06:00 EDT
As described by above attachment, reporting from within Anaconda installer is also affected. Raising priority and severity.
Comment 4 David Kutálek 2010-08-19 05:09:09 EDT
From within Anaconda, it is not possible to create a new case for GSS.
But attaching to existing case works.
Comment 6 Andrew Hecox 2010-08-19 07:25:02 EDT
Chris -- is the latest version of report from the RHEL repos pulled in automatically?
Comment 8 Chris Lumens 2010-08-19 09:50:06 EDT
> Chris -- is the latest version of report from the RHEL repos pulled in
> automatically?

Yes, whatever's current in the repo when buildinstall is run is what will be pulled into the install images.
Comment 10 Gavin Romig-Koch 2010-08-20 19:12:58 EDT
(In reply to comment #2)
> Created attachment 439622 [details]
> Server complains about the product - from within Anaconda
> 
> 'Redhat is not a valid product' sounds horribly. We should definitely fix it.

What installation media are you using to get this result from Anaconda, when i try it with the latest nightly build it works fine.

(I am able to reproduce the selinux case, so there is a problem, just i can't reproduce it in anaconda)
Comment 11 Gavin Romig-Koch 2010-08-20 20:55:52 EDT
Created attachment 440075 [details]
Fixes this bz
Comment 12 Gavin Romig-Koch 2010-08-20 21:04:03 EDT
I need a blocker+ before i can push/tag/build the fix for this.  Please let me know what

The patch is attached to this bz.

The scratch build is at: https://brewweb.devel.redhat.com/taskinfo?taskID=2697670

I've tested this fix within an installed RHEL6 latest nightly using sealert, which now works correctly with this fix.

I've also tested this fix while installing RHEL6 latest nightly, and this fix doesn't break it.
Comment 13 Gavin Romig-Koch 2010-08-20 21:30:24 EDT
Ah, I just figured out why i could not reproduce this problem under anaconda.  Yes, this change does also fix the above mentioned problem under anaconda.
Comment 14 David Kutálek 2010-08-23 07:58:02 EDT
I tried your scratch build.

It fixes problems with sealert.
I suppose it also fixes Anaconda problem, but I don't know how to get Anaconda installer using scratch-build report lib. When in compose, it should be easy and quick to test Anaconda too. I also run all other automated tests to be sure this does not break something, seems ok.

So, I would say we are ready to receive a blocker now :-).
Comment 19 releng-rhel@redhat.com 2010-11-10 16:29:52 EST
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.