Bug 625148 - RFE: Please upgrade to 0.6 so that trac 0.12 can be used
Summary: RFE: Please upgrade to 0.6 so that trac 0.12 can be used
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: python-genshi (Show other bugs)
(Show other bugs)
Version: 6.0
Hardware: All Linux
low
medium
Target Milestone: rc
: ---
Assignee: Dave Malcolm
QA Contact: qe-baseos-daemons
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-08-18 17:57 UTC by Jesse Keating
Modified: 2013-01-10 03:34 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-06-09 18:14:56 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
For reference, the diff between the prepped python-genshi-0.5.1-7.1.src.rpm, and Genshi-0.6.tar.gz2 (1.44 MB, patch)
2010-08-19 21:58 UTC, Dave Malcolm
no flags Details | Diff

Description Jesse Keating 2010-08-18 17:57:49 UTC
The Trac maintainer tells me that in order to use the current supported trac (0.12) in EPEL6 we need at least python-genshi 0.6.  Right now 0.5.x is shipped.  Would it be possible to update it?

Comment 2 RHEL Product and Program Management 2010-08-18 18:17:35 UTC
This feature request has been proposed after Feature Freeze and we
are unable to resolve it in time for the current Red Hat Enterprise
Linux release. It has been denied for the current release and
proposed for the next Red Hat Enterprise Linux release.

Comment 3 Dave Malcolm 2010-08-19 19:43:19 UTC
Upstream notes on changes in 0.6.0:
  http://genshi.edgewall.org/browser/tags/0.6.0/ChangeLog

Comment 4 Dave Malcolm 2010-08-19 21:58:20 UTC
Created attachment 439805 [details]
For reference, the diff between the prepped python-genshi-0.5.1-7.1.src.rpm, and Genshi-0.6.tar.gz2

Comment 10 Dave Malcolm 2011-06-09 18:12:50 UTC
Note that there's now a python-genshi06 in EPEL6:
  https://admin.fedoraproject.org/pkgdb/acls/name/python-genshi06

and that EPEL6 now has Trac 0.12:
  http://koji.fedoraproject.org/koji/packageinfo?packageID=4008

albeit with some patching:
http://pkgs.fedoraproject.org/gitweb/?p=trac.git;a=commitdiff;h=0a3ce7730d155e2e81a88b915be2c130b93df2f0

http://pkgs.fedoraproject.org/gitweb/?p=trac.git;a=commitdiff;h=310803ecd541d28fc6d23786e502221d3eca3054

So it would seem that the initial motivation for this has been resolved, from the EPEL side.

Comment 11 RHEL Product and Program Management 2011-06-09 18:14:56 UTC
Development Management has reviewed and declined this request.  You may appeal
this decision by reopening this request.


Note You need to log in before you can comment on or make changes to this bug.