Bug 625369 - preupgrade update path is broken on F-13, F-14 and rawhide
preupgrade update path is broken on F-13, F-14 and rawhide
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: preupgrade (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-19 04:05 EDT by Alex Lancaster
Modified: 2010-10-15 08:44 EDT (History)
2 users (show)

See Also:
Fixed In Version: preupgrade-1.1.8-1.fc14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-10-15 08:44:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alex Lancaster 2010-08-19 04:05:01 EDT
It appears that the preupgrade N-V-R for F-12 > F-13, F-14 and rawhide currently, meaning that users upgrading from older releases will either get the old version, or will fail to upgrade.  According to Fedora Community:

https://admin.fedoraproject.org/community/?package=preupgrade#package_maintenance

here are the current versions:

rawhide 
	1.1.6-3.fc14 	
Fedora 14 
	1.1.6-3.fc14 	
Fedora 13 
	1.1.4-1.fc13 	
Fedora 12 
	1.1.7-1.fc12 	

Please push 1.1.7 to all active branches (or at least to updates-testing) and rawhide to fix this ASAP.  Thanks.
Comment 1 Alex Lancaster 2010-09-09 12:08:09 EDT
Ping?   This is still an issue with F-12 > F-13 and F-12 > F-14

 1.1.7-1.fc12 > 1.1.4-1.fc13
 1.1.4-1.fc13 > 1.1.6-3.fc14

At least rawhide (f15) is ahead of all the other branches.
Comment 2 Richard Hughes 2010-09-09 12:38:41 EDT
I've built F13, F14 and rawhide versions of preupgrade now. Thanks for the ping. Positive karma appreciated in bohdi.
Comment 3 Alex Lancaster 2010-09-09 14:24:37 EDT
(In reply to comment #2)
> I've built F13, F14 and rawhide versions of preupgrade now. Thanks for the
> ping. Positive karma appreciated in bohdi.

Will do, but could you please add this bug to bodhi.  I've re-opened the bug because the bodhi push should really close it once it's pushed to stable as per the usual bodhi workflow.
Comment 4 Alex Lancaster 2010-09-09 14:25:39 EDT
(Only really need to add the bug for the f13 and f12 bodhi updates, btw.)
Comment 5 Fedora Update System 2010-09-23 06:04:25 EDT
preupgrade-1.1.8-1.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/preupgrade-1.1.8-1.fc14
Comment 6 Fedora Update System 2010-10-15 08:44:22 EDT
preupgrade-1.1.8-1.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.