Bug 62543 - GCC Will not compile kde network 2.2.2 from source
GCC Will not compile kde network 2.2.2 from source
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: kdenetwork (Show other bugs)
7.2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-04-02 06:07 EST by Matt Darcy
Modified: 2007-04-18 12:41 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-02 12:56:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matt Darcy 2002-04-02 06:07:45 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0)

Description of problem:
Hi, 

I am using 
gcc-2.96-98
gcc-c++-2.96-98
gcc-g77-2.96-98
gcc-objc-2.96-98

I am trying have ran ./configure with no flags and it has not complained on any 
faults.  When I run "make all"

I get the following compelation errorg++ -DHAVE_CONFIG_H -I. -I. -I.. -
I/usr/lib/qt-2.3.1/include -I/usr/X11R6/inclu
e -IKSOpenkSirc -D_REENTRANT -O2 -fno-exceptions -fno-check-new -DQT_CLEAN_NAME
PACE -DQT_NO_COMPAT -DQT_NO_ASCII_CAST -fexceptions -UQT_NO_ASCII_CAST -c ioBro
dcast.cpp  -fPIC -DPIC -o .libs/ioBroadcast.o
/usr/lib/qt-2.3.1/bin/moc ./ksircprocess.h -o ksircprocess.moc
/bin/sh ../libtool --mode=compile --tag=CXX g++ -DHAVE_CONFIG_H -I. -I. -I.. -I
usr/lib/qt-2.3.1/include -I/usr/X11R6/include  -IKSOpenkSirc  -D_REENTRANT  -O2
-fno-exceptions -fno-check-new -DQT_CLEAN_NAMESPACE -DQT_NO_COMPAT -DQT_NO_ASCI
_CAST -fexceptions -UQT_NO_ASCII_CAST -c ksircprocess.cpp
g++ -DHAVE_CONFIG_H -I. -I. -I.. -I/usr/lib/qt-2.3.1/include -I/usr/X11R6/inclu
e -IKSOpenkSirc -D_REENTRANT -O2 -fno-exceptions -fno-check-new -DQT_CLEAN_NAME
PACE -DQT_NO_COMPAT -DQT_NO_ASCII_CAST -fexceptions -UQT_NO_ASCII_CAST -c ksirc
rocess.cpp  -fPIC -DPIC -o .libs/ksircprocess.o
In file included from ksircprocess.cpp:111:
/usr/include/stdlib.h:604: declaration of `int setenv (const char *,
const char *, int) throw ()' throws different exceptions
../config.h:225: than previous declaration `int setenv (const char *,
const char *, int)'
/usr/include/stdlib.h:607: declaration of `int unsetenv (const char *)
throw ()' throws different exceptions
../config.h:233: than previous declaration `int unsetenv (const char
*)'
make[3]: *** [ksircprocess.lo] Error 1
make[3]: Leaving directory `/usr/local/src/kde-2.2.2/kdenetwork-2.2.2/ksirc'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/usr/local/src/kde-2.2.2/kdenetwork-2.2.2/ksirc'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/usr/local/src/kde-2.2.2/kdenetwork-2.2.2'
make: *** [all-recursive-am] Error 2



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.run configure on kdenetwork 2.2.2
2.type make all
3.
	

Actual Results:  Get the error message g++ -DHAVE_CONFIG_H -I. -I. -I.. -
I/usr/lib/qt-2.3.1/include -I/usr/X11R6/inclu
e -IKSOpenkSirc -D_REENTRANT -O2 -fno-exceptions -fno-check-new -DQT_CLEAN_NAME
PACE -DQT_NO_COMPAT -DQT_NO_ASCII_CAST -fexceptions -UQT_NO_ASCII_CAST -c ioBro
dcast.cpp  -fPIC -DPIC -o .libs/ioBroadcast.o
/usr/lib/qt-2.3.1/bin/moc ./ksircprocess.h -o ksircprocess.moc
/bin/sh ../libtool --mode=compile --tag=CXX g++ -DHAVE_CONFIG_H -I. -I. -I.. -I
usr/lib/qt-2.3.1/include -I/usr/X11R6/include  -IKSOpenkSirc  -D_REENTRANT  -O2
-fno-exceptions -fno-check-new -DQT_CLEAN_NAMESPACE -DQT_NO_COMPAT -DQT_NO_ASCI
_CAST -fexceptions -UQT_NO_ASCII_CAST -c ksircprocess.cpp
g++ -DHAVE_CONFIG_H -I. -I. -I.. -I/usr/lib/qt-2.3.1/include -I/usr/X11R6/inclu
e -IKSOpenkSirc -D_REENTRANT -O2 -fno-exceptions -fno-check-new -DQT_CLEAN_NAME
PACE -DQT_NO_COMPAT -DQT_NO_ASCII_CAST -fexceptions -UQT_NO_ASCII_CAST -c ksirc
rocess.cpp  -fPIC -DPIC -o .libs/ksircprocess.o
In file included from ksircprocess.cpp:111:
/usr/include/stdlib.h:604: declaration of `int setenv (const char *,
const char *, int) throw ()' throws different exceptions
../config.h:225: than previous declaration `int setenv (const char *,
const char *, int)'
/usr/include/stdlib.h:607: declaration of `int unsetenv (const char *)
throw ()' throws different exceptions
../config.h:233: than previous declaration `int unsetenv (const char
*)'
make[3]: *** [ksircprocess.lo] Error 1
make[3]: Leaving directory `/usr/local/src/kde-2.2.2/kdenetwork-2.2.2/ksirc'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/usr/local/src/kde-2.2.2/kdenetwork-2.2.2/ksirc'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/usr/local/src/kde-2.2.2/kdenetwork-2.2.2'
make: *** [all-recursive-am] Error 2

Expected Results:  kdenetwork 2.2.2 to compile without problem and allow 
install.

Additional info:

When I run the final g++ command on its own I get

[root@jordan kdenetwork-2.2.2]# g++ -DHAVE_CONFIG_H -I. -I. -I.. -I/usr/lib/qt-
2.3.1/include -I/usr/X11R6/include --IKSOpenkSirc -D_REENTRANT -O2 -fno-excepti
ons -fno-check-new -DQT_CLEAN_NAMESPACE -DQT_NO_COMPAT -DQT_NO_ASCII_CAST -fexc
eptions -UQT_NO_ASCII_CAST -c ksircprocess.cpp -fPIC -DPIC -o .libs/ksircproces
s.o
g++: ksircprocess.cpp: No such file or directory
g++: No input files
[root@jordan kdenetwork-2.2.2]#
Comment 1 Jakub Jelinek 2002-04-02 12:10:57 EST
Doesn't look like an gcc bug.
Most likely something got wrong during configure time, because
config.h shouldn't add setenv() and unsetenv() prototypes.
The second problem is just that you forgot to cd ksirc first.
Comment 2 Bernhard Rosenkraenzer 2002-04-02 12:55:59 EST
Use our source RPM, that fixes the bug in the base tarball.
Comment 3 Matt Darcy 2002-04-02 15:40:25 EST
If this is a problem with the KDEnetwork source 2.2.2 then should this not 
be passed to kdenetwork as a problem ?

The gcc bug does appear to be a problem when working with the out put of 
configure.

I am not really impressed with the "use RPM" sollution" I am trying not to use 
RPMS on my system at the moment to get it tuned to source use.

Can this please be re-evalutated.

Thanks, 

Note You need to log in before you can comment on or make changes to this bug.