Bug 625462 - Conflict between ssl.conf and pulp.conf
Conflict between ssl.conf and pulp.conf
Status: CLOSED DUPLICATE of bug 618681
Product: Pulp
Classification: Community
Component: z_other (Show other bugs)
unspecified
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Pradeep Kilambi
wes hayutin
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-19 10:08 EDT by dgao
Modified: 2011-07-15 15:31 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-19 14:40:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description dgao 2010-08-19 10:08:37 EDT
Description of problem:

When installing pulp from yum, a conflict occurred when starting apache. The default ssl module and the pulp module both tried to listen on port 443, which stopped apache from starting. 

Version-Release number of selected component (if applicable):
0.0.52

How reproducible:
Every time as long as ssl.conf and pulp.conf exists in /etc/httpd/conf.d. 

Steps to Reproduce:
1. yum install pulp
2. service httpd restart
  
Actual results:

[root@pulp conf.d]# service httpd restart
Stopping httpd:                                            [  OK  ]
Starting httpd: [Thu Aug 19 09:43:19 2010] [warn] module ssl_module is already loaded, skipping
httpd: Could not reliably determine the server's fully qualified domain name, using 127.0.0.1 for ServerName
[Thu Aug 19 09:43:19 2010] [warn] _default_ VirtualHost overlap on port 443, the first has precedence
(98)Address already in use: make_sock: could not bind to address [::]:443
                                                           [  OK  ]

[root@pulp conf.d]# netstat -altp | grep "httpd"
[root@pulp conf.d]#

Expected results:

[root@pulp conf.d]# service httpd restart
Stopping httpd:                                            [  OK  ]
Starting httpd: httpd: Could not reliably determine the server's fully qualified domain name, using 127.0.0.1 for ServerName
                                                           [  OK  ]
[root@pulp conf.d]# netstat -altp | grep "httpd"
tcp        0      0 *:8811                      *:*                         LISTEN      21187/httpd         
tcp        0      0 *:http                      *:*                         LISTEN      21187/httpd         
tcp        0      0 *:https                     *:*                         LISTEN      21187/httpd         
[root@pulp conf.d]#

Additional info:

Known workaround exists in pulp-dev.py but is only executed during source install (python setup.py install). 

114: # Disable existing SSL configuration
115:     if os.path.exists('/etc/httpd/conf.d/ssl.conf'):
116:         shutil.move('/etc/httpd/conf.d/ssl.conf', 
117:             '/etc/httpd/conf.d/ssl.off')
Comment 1 Preethi Thomas 2010-08-19 14:32:09 EDT
seems like the same issue as in
https://bugzilla.redhat.com/show_bug.cgi?id=618681
Comment 2 Preethi Thomas 2010-08-19 14:40:52 EDT

*** This bug has been marked as a duplicate of bug 618681 ***

Note You need to log in before you can comment on or make changes to this bug.