Bug 625486 - [abrt] remmina-0.7.5-1.fc13: remmina_connection_holder_on_switch_page_real: Process /usr/bin/remmina was killed by signal 11 (SIGSEGV)
[abrt] remmina-0.7.5-1.fc13: remmina_connection_holder_on_switch_page_real: P...
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: remmina (Show other bugs)
13
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Christoph Wickert
Fedora Extras Quality Assurance
abrt_hash:1738bd1df68fda151e8c3010d91...
:
: 626597 627650 636558 640073 651664 660021 665469 673681 680971 701831 725738 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-19 11:27 EDT by Jeff Raber
Modified: 2011-07-26 08:42 EDT (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-02-25 17:06:01 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (15.29 KB, text/plain)
2010-08-19 11:27 EDT, Jeff Raber
no flags Details

  None (edit)
Description Jeff Raber 2010-08-19 11:27:14 EDT
abrt version: 1.1.13
architecture: x86_64
Attached file: backtrace
cmdline: remmina -c /home/jeff/.remmina/1275414394078.remmina
comment: Crash has only occured once.  So far I have been unable to reproduce the crash.
component: remmina
crash_function: remmina_connection_holder_on_switch_page_real
executable: /usr/bin/remmina
kernel: 2.6.33.6-147.2.4.fc13.x86_64
package: remmina-0.7.5-1.fc13
rating: 4
reason: Process /usr/bin/remmina was killed by signal 11 (SIGSEGV)
release: Fedora release 13 (Goddard)
time: 1282231039
uid: 500

How to reproduce
-----
1.  Connect to another computer using RDP by using a saved connection and the Remmina applet on the Gnome toolbar.
2.  Use that connection for a while (between 15-45minutes)
3.  Close that session by logging off of the server.
Comment 1 Jeff Raber 2010-08-19 11:27:16 EDT
Created an attachment (id=439716)
File: backtrace
Comment 2 Christoph Wickert 2010-09-27 18:17:50 EDT
*** Bug 636558 has been marked as a duplicate of this bug. ***
Comment 3 Christoph Wickert 2010-09-27 18:19:04 EDT
Coping over the comment from bug 636558

How to reproduce
-----
1.Had remote desktops to 3 different machines running
2.In two of the RD's I was running cygwinX's xwin.exe :1 -query host to connect
to a clients xdmcp
3.The RD's screen's would not refresh changes properly when I would click on
items in the RD's Xdisplay.
Comment 4 Douglas Lattman 2010-09-27 19:56:52 EDT
remina->win xp +-> cgwin xwin.exe :1 -query host1 -> fedora x86_64 w/ xwmcp
               +-> cgwin xwin.exe :2 -query host2 -> redhat x86_64 w/ xwmcp
               +-> cgwin xwin.exe :3 -query host3 -> redhat x86_64 w/ xwmcp
When I'm on the winxp I have no issues with my xwin displays
When I use remina to connect to the win xp, the screens do not refresh properly.
If I alt tab between windows, the previous window does not clear out of the xwin.exe root for the corresponding :1-:3 desktops.
The remina died after running for a few hours.
If I do an ls in a term window on the remina connected xdisplay, then ls may not even show on the screen. However, if I minimize the term window, and then click to have it re-appear it will refresh and the ls will show.
I do not have this issue when I am working locally on the win xp computer.
Comment 5 Christoph Wickert 2010-10-04 13:36:10 EDT
*** Bug 640073 has been marked as a duplicate of this bug. ***
Comment 6 Christoph Wickert 2010-11-28 12:45:13 EST
*** Bug 626597 has been marked as a duplicate of this bug. ***
Comment 7 Christoph Wickert 2010-11-28 12:45:22 EST
*** Bug 627650 has been marked as a duplicate of this bug. ***
Comment 8 Christoph Wickert 2010-12-04 21:45:16 EST
*** Bug 660021 has been marked as a duplicate of this bug. ***
Comment 9 Christoph Wickert 2010-12-24 04:06:07 EST
*** Bug 651664 has been marked as a duplicate of this bug. ***
Comment 10 Christoph Wickert 2010-12-24 04:06:44 EST
*** Bug 665469 has been marked as a duplicate of this bug. ***
Comment 11 Christoph Wickert 2011-01-29 17:58:30 EST
*** Bug 673681 has been marked as a duplicate of this bug. ***
Comment 12 Christoph Wickert 2011-02-25 17:06:01 EST
Thanks for submitting this crash report. Unfortunately there is not much use in forwarding this bug to the upstream developers because they have completely rewritten remmina in the meantime and don't want to be bothered with bugs in old code. Because of our updates policy [1] I cannot update to the new release in Fedora 13 and 14.

Updated remmina packages are now available from 
http://repos.fedorapeople.org/repos/cwickert/remmina/
Please keep in mind that the plugins are no longer part of the main application and you have to install the plugins you want manually.

Warning: These are no official Fedora packages. They are not signed and if you hit any troubles with them, please don't file bugs in Bugzilla but contact me directly.

[1] https://fedoraproject.org/wiki/Updates_Policy
Comment 13 Christoph Wickert 2011-02-28 12:32:23 EST
*** Bug 680971 has been marked as a duplicate of this bug. ***
Comment 14 Christoph Wickert 2011-05-04 03:50:44 EDT
*** Bug 701831 has been marked as a duplicate of this bug. ***
Comment 15 Christoph Wickert 2011-07-26 08:42:14 EDT
*** Bug 725738 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.