Bug 625590 - sendmail complains no sender address resolves, mail bounces
sendmail complains no sender address resolves, mail bounces
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: sendmail (Show other bugs)
rawhide
x86_64 Linux
low Severity urgent
: ---
: ---
Assigned To: Jaroslav Škarvada
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-19 17:36 EDT by Horst H. von Brand
Modified: 2010-08-22 21:45 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-22 21:45:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Horst H. von Brand 2010-08-19 17:36:40 EDT
Description of problem:
I was intrigued to see no mail arriving, and found out sendmail wasn't resolving any mail origin. I checked that DNS is working, and tried several of the non-resolving domains with host(1), DNS answered OK. I'm relaying mail here via fetchmail-6.3.17-1.fc14.x86_64

Version-Release number of selected component (if applicable):
sendmail-8.14.4-11.fc15.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Start sendmail
2.
3.
  
Actual results:
Mail bounces, in /var/log/maillog  I get e.g.

Aug 19 17:29:44 laptop14 sendmail[22525]: o7JKEw1E022525: from=<ambassadors-bounces@lists.fedoraproject.org>, size=3928, class=0, nrcpts=0, bodytype=7BIT, proto=ESMTP, daemon=MTA, relay=laptop14.inf.utfsm.cl [127.0.0.1]
Aug 19 17:29:44 laptop14 sendmail[22525]: o7JKEw1F022525: ruleset=check_mail, arg1=<devel-bounces@lists.fedoraproject.org>, relay=laptop14.inf.utfsm.cl [127.0.0.1], reject=451 4.1.8 Domain of sender address devel-bounces@lists.fedoraproject.org does not resolve
Aug 19 17:29:44 laptop14 sendmail[22525]: o7JKEw1F022525: from=<devel-bounces@lists.fedoraproject.org>, size=4938, class=0, nrcpts=0, bodytype=7BIT, proto=ESMTP, daemon=MTA, relay=laptop14.inf.utfsm.cl [127.0.0.1]

Expected results:
Get mail...

Additional info:
Comment 1 Horst H. von Brand 2010-08-19 17:41:29 EDT
Going back to sendmail-8.14.4-10.fc15.x86_64 makes it work.
Comment 2 Jaroslav Škarvada 2010-08-20 05:14:40 EDT
I am unable to reproduce this, sendmail-8.14.4-11.fc15.x86_64 in rawhide testing environment works OK for me. Please note there shouldn't be any change in functionality between release 10 and 11, please check: http://pkgs.fedoraproject.org/gitweb/?p=sendmail.git;a=commitdiff;h=c8ac1bc90081f1b70700b23ca708e2f69f2bfabb;hp=d89cc2df32c5164dec5a6e53d1016b716e249aad

Can you recheck and provide more details? Please note that I tested with selinux in permissive mode as there are still some bugs in selinux policy in rawhide preventing users from successfull log-in (also note if selinux is the core of your problem, it should be reported against selinux).
Comment 3 Horst H. von Brand 2010-08-22 21:45:34 EDT
Very strange... I'm running with SELinux in enforcing mode without any particular trouble here (x86_64).

And you are right, nothing there should affect the workings in any way (modulo compiler/library differences).

OK, seems I found out what is going on: This &#@~$ kernel drops the WiFi network connection at random, and so obviously everything goes south.

I'm getting mail normally after getting the network going again.

Sorry for the noise.

[Please add PILOT ERROR ("I'M AN IDIOT" is too strong ;-) to Status]

Note You need to log in before you can comment on or make changes to this bug.