Bug 625752 - NPE in Resource Config update
Summary: NPE in Resource Config update
Status: CLOSED CURRENTRELEASE
Alias: None
Product: RHQ Project
Classification: Other
Component: Core Server   
(Show other bugs)
Version: 4.0.0
Hardware: All
OS: Linux
low
high vote
Target Milestone: ---
: ---
Assignee: RHQ Project Maintainer
QA Contact: Mike Foley
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-08-20 10:49 UTC by Heiko W. Rupp
Modified: 2014-06-19 15:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-19 15:10:09 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Heiko W. Rupp 2010-08-20 10:49:06 UTC
I can't exactly tell, what I did other than trying to set the connection properties (credentials) for a JBAS. This was on a slow and loaded box, so I probably have clicked the "save" button multiple times in the GWT UI.


Caused by: java.lang.NullPointerException
        at org.rhq.core.domain.configuration.AbstractResourceConfigurationUpdate.<init>(AbstractResourceConfigurationUpdate.java:73)
        at org.rhq.core.domain.configuration.PluginConfigurationUpdate.<init>(PluginConfigurationUpdate.java:153)
        at org.rhq.enterprise.server.configuration.ConfigurationManagerBean.updatePluginConfiguration(ConfigurationManagerBean.java:252)


This can happen if no config to deepCopy is passed into the constructor.

- we should guard the UI from double submissions
- the AbstractResourceConfigurationUpdate() should check for null.


Note You need to log in before you can comment on or make changes to this bug.