Bug 62576 - /boot/kernel.h wrong for bigmem kernel
/boot/kernel.h wrong for bigmem kernel
Status: CLOSED DUPLICATE of bug 62150
Product: Red Hat Linux
Classification: Retired
Component: initscripts (Show other bugs)
7.3
i386 Linux
high Severity high
: ---
: ---
Assigned To: Bill Nottingham
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-04-02 12:42 EST by Matt Domsch
Modified: 2014-03-16 22:26 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-02 12:53:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matt Domsch 2002-04-02 12:42:51 EST
Description of Problem:
kernel 2.4.18-0.12 and earlier

The kernel boot file  /boot/kernel.h is wrong. The boot file set the 
flag "#define __BOOT_KERNEL_UP 1" which 
is very wrong because the BIGMEM kernel is a SMP kernel.
This can be proved by trying the following:
cd /boot
strings vmlinux-2.4.18-0.4bigmem | grep register_chrdev
You will see register_chrdev_Rsmp_515ed577 symbol for the register_chrdev 
kernel function.

The fixes for the /boot/kernel.h are as follows:
Add the following lines:

// Note, this flag needs the be defined, so the "rhconfig.h" can use this flag
// to define the variable "__module__bigmem"
#ifndef __BOOT_KERNEL_BIGMEM
#define __BOOT_KERNEL_BIGMEM 1
#endif

// Note, this flag is required so the system can pick up the correct SMP kernel
// symbols. BIGMEM is a SMP kernel.
#ifndef __BOOT_KERNEL_SMP
#define __BOOT_KERNEL_SMP 1
#endif


Version-Release number of selected component (if applicable):
2.4.18-0.12 and earlier

Dell considers this a MUST-FIX for Hampton.
Comment 1 Matt Domsch 2002-04-02 12:52:55 EST
With kernel 2.4.18-0.12bigmem and initscripts-6.60-1, this is half-right.
#define __MODULE_KERNEL_i686 1
#define __BOOT_KERNEL_ENTERPRISE 0
#define __BOOT_KERNEL_BIGMEM 1
#define __BOOT_KERNEL_SMP 0    (this is wrong)
#define __BOOT_KERNEL_UP 0

Comment 2 Bill Nottingham 2002-04-02 12:57:14 EST
Actually, I think this is right... using the bigmem defines should get the
correct  bigmem symbols. SMP/UP/ENTERPRISE/BIGMEM refers to the kernel 'name',
not the features.

*** This bug has been marked as a duplicate of 62150 ***

Note You need to log in before you can comment on or make changes to this bug.