Bug 625846 - Can't add extra arguments to dhcrelay daemon
Can't add extra arguments to dhcrelay daemon
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: dhcp (Show other bugs)
6.1
All Linux
low Severity low
: rc
: ---
Assigned To: Jiri Popelka
Release Test Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-20 11:31 EDT by Jiri Popelka
Modified: 2011-05-19 10:04 EDT (History)
6 users (show)

See Also:
Fixed In Version: dhcp-4.1.1-13.P1.el6
Doc Type: Bug Fix
Doc Text:
Previously, it was impossible to configure the dhcrelay service to run the dhcrelay daemon with additional arguments. With this update, a DHCRELAYARGS variable is available for the /etc/sysconfig/dhcrelay configuration file, which allows additional arguments to be passed to the dhcrelay daemon properly.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-05-19 10:04:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jiri Popelka 2010-08-20 11:31:46 EDT
+++ This bug was initially created as a clone of Bug #624965 +++

Description of problem:
In our network, we have to use the -a option for the dhcrelay daemon. Currently, I see no 'clean' way to achieve this: only the variables INTERFACES and DHCPSERVERS can be changed.

Version-Release number of selected component (if applicable):
dhcp-3.0.5-23.el5_5.1

How reproducible:
Always

Steps to Reproduce:
1. Try to add -a somewhere to /etc/sysconfig/dhcrelay, but you fail to do so.
  
Actual results:
dhcrelay agent running without -a

Expected results:
dhcrelay agent running with -a

Additional info:
As a workaround, we add '-a' sneakely to variable DHCPSERVERS in /etc/sysconfig/dhcrelay, for instance
  DHCPSERVERS="-a 10.120.3.250"

Other initscripts use a configurable variables for this situation: DHCPDARGS (dhcpd), SYSLOGD_OPTIONS (syslog), EXTRAOPTIONS (xinetd). That is my suggestion to fix this bug.

--- Additional comment from jpopelka@redhat.com on 2010-08-20 14:04:42 CEST ---

Variable EXTRAOPTIONS (for options other than -i) sounds good to me.
Comment 1 Jiri Popelka 2010-08-20 11:35:32 EDT
http://pkgs.fedoraproject.org/gitweb/?p=dhcp.git;a=commitdiff;h=1eb7b33d5572d8c8dc3230ae3204f674bee3ca42

Low priority because there's a workaround in 'sneakily' misusing the DHCPSERVERS variable.

Version-Release number of selected component (if applicable):
dhcp-4.1.1-11.P1.el6
Comment 5 Tomas Capek 2011-05-10 10:22:54 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Previously, it was impossible to configure the dhcrelay service to run the dhcrelay daemon with additional arguments. With this update, a DHCRELAYARGS variable is available for the /etc/sysconfig/dhcrelay configuration file, which allows additional arguments to be passed to the dhcrelay daemon properly.
Comment 6 errata-xmlrpc 2011-05-19 10:04:57 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-0697.html

Note You need to log in before you can comment on or make changes to this bug.