Bug 625862 - [fr_FR] %s is shown as it is in Translated GUI instead of variable value
Summary: [fr_FR] %s is shown as it is in Translated GUI instead of variable value
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: anaconda (Show other bugs)
(Show other bugs)
Version: 6.1
Hardware: All Linux
low
medium
Target Milestone: rc
: ---
Assignee: Anaconda Maintenance Team
QA Contact: QE Internationalization Bugs
URL:
Whiteboard:
Keywords: Translation
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-08-20 16:12 UTC by A S Alam
Modified: 2013-07-03 01:03 UTC (History)
8 users (show)

Fixed In Version: anaconda-13.21.84-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-05-19 12:34:30 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
fr_FR with Broken translation (62.89 KB, image/png)
2010-08-20 16:12 UTC, A S Alam
no flags Details
Fixed translation (203.34 KB, image/png)
2011-03-09 13:33 UTC, Alexander Todorov
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:0530 normal SHIPPED_LIVE anaconda bug fix and enhancement update 2011-05-18 17:44:52 UTC

Description A S Alam 2010-08-20 16:12:18 UTC
Created attachment 439981 [details]
fr_FR with Broken translation

Description of problem:
during installation in fr_FR (French), at "Basic/Advance Disk", there is string
"%s périphériques (%s) sélectionnés sur un total de %s périphériques (%"
"s)".
it is problem in fr_FR, de_DE, gu_IN is working fine, replacing %s with respective variable.
Screenshot with Red Line

Version-Release number of selected component (if applicable):
anaconda-13.21.78-1.el6.x86_64.rpm

How reproducible:
100%

Steps to Reproduce:
1. run installation by selection French language
2. Select "Specialized Storage Devices"
3. Check translation at 2nd last line
  
Actual results: %s are there
"%s périphériques (%s) sélectionnés sur un total de %s périphériques (%"
"s)".

Expected results: No %s shold be in there

Additional info:
"PO-Revision-Date: 2010-08-09 17:15+1000\n"

Comment 2 Manuel Ospina 2010-08-23 00:37:17 UTC
I can't see any error in the PO file: 

6401 #: ui/filter.glade.h:2
6402 #, no-c-format
6403 msgid "<b>%s devices (%s) selected</b> out of %s devices (%s) total."
6404 msgstr ""
6405 "<b>%s périphériques (%s) sélectionnés</b> sur un total de %s périphériques (%"
6406 "s)."

from: 

https://translate.fedoraproject.org/projects/p/anaconda/c/rhel6-branch/view/po/fr.po

Comment 3 Parag Nemade 2010-08-23 09:14:36 UTC
We tried to debug the problem further by changing translated string using different combination but still unable to find where exactly is the problem. strangely whatever you replace as a translated string, its appearing as it is in UI without any variable value.

Comment 4 Ankit Patel 2010-09-01 09:56:03 UTC
(In reply to comment #2)
> I can't see any error in the PO file: 
> 
> 6401 #: ui/filter.glade.h:2
> 6402 #, no-c-format
> 6403 msgid "<b>%s devices (%s) selected</b> out of %s devices (%s) total."
> 6404 msgstr ""
> 6405 "<b>%s périphériques (%s) sélectionnés</b> sur un total de %s
> périphériques (%"
> 6406 "s)."
> 
> from: 
> 
> https://translate.fedoraproject.org/projects/p/anaconda/c/rhel6-branch/view/po/fr.po

Hi Manuel/Sam,

Following message was causing the issue:

=== start ==
2737 #: iw/filter_gui.py:151
2738 #, python-format
2739 msgid "<b>%s device(s) (%s MB) selected</b> out of %s device(s) (%s MB) total."
2740 msgstr ""
2741 "<b>%s périphérique(s) (%s Mo) sélectionné(s) sur un total de %s périphérique"
2742 "(s) (%s Mo)."
=== end ===

you might want to put "</b>" the closing tag for bold text in your translations.

Thanks!
Ankit

Comment 5 Ankit Patel 2010-09-01 09:58:44 UTC
(In reply to comment #3)
> We tried to debug the problem further by changing translated string using
> different combination but still unable to find where exactly is the problem.
> strangely whatever you replace as a translated string, its appearing as it is
> in UI without any variable value.

Thanks for looking into the issue Parag, but there are actually two similar messages under anaconda.fr.po file, because of which it was confusing.

2737 #: iw/filter_gui.py:151
2738 #, python-format
2739 msgid "<b>%s device(s) (%s MB) selected</b> out of %s device(s) (%s MB) total."
2740 msgstr ""
2741 "<b>%s périphérique(s) (%s Mo) sélectionné(s) sur un total de %s périphérique"
2742 "(s) (%s Mo)."


and the other one is


6401 #: ui/filter.glade.h:2
6402 #, no-c-format
6403 msgid "<b>%s devices (%s) selected</b> out of %s devices (%s) total."
6404 msgstr ""
6405 "<b>%s périphériques (%s) sélectionnés</b> sur un total de %s périphériques (%"
6406 "s)."


Thanks again!
Ankit

Comment 6 Parag Nemade 2010-09-01 10:14:58 UTC
Thanks Ankit for the fix.

Comment 7 Terry CHUANG 2010-12-06 07:01:17 UTC
zh-TW Tranditional Chinese bug has been fixed and commited through Transifex.

Comment 8 Sam Friedmann 2010-12-06 07:28:41 UTC
fr-FR bug has been fixed and submitted on Transifex.
Thanks,

Sam

Comment 9 Ankit Patel 2010-12-06 07:33:04 UTC
(In reply to comment #8)
> fr-FR bug has been fixed and submitted on Transifex.
> Thanks,
> 
> Sam

Thanks for the fix Sam.

Commit diff: http://git.fedorahosted.org/git?p=anaconda.git;a=commitdiff;h=ce1d4d8c7f2f19a8fd6ca6a73e382b74a2ad8ec3

I have tested the fix and it's perfectly working fine at my end.

Now, reassigning the bug back to the owner of the component to get this fix included in the next build and get this bug resolved.

Thanks!
Ankit

Comment 10 Chris Lumens 2010-12-06 14:22:43 UTC
We automatically pick up translation fixes as part of the build process.

Comment 12 Alexander Todorov 2011-03-09 13:33:05 UTC
Created attachment 483215 [details]
Fixed translation

This is with anaconda-13.21.103-1.el6.x86_64.

Comment 13 errata-xmlrpc 2011-05-19 12:34:30 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-0530.html


Note You need to log in before you can comment on or make changes to this bug.