Bug 625872 - CJKI Rendering is broken if use Alt+Ctrl+Backspace, use TUI installer...
Summary: CJKI Rendering is broken if use Alt+Ctrl+Backspace, use TUI installer...
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: anaconda (Show other bugs)
(Show other bugs)
Version: 6.1
Hardware: All Linux
low
medium
Target Milestone: rc
: ---
Assignee: Anaconda Maintenance Team
QA Contact: QE Internationalization Bugs
URL:
Whiteboard:
Keywords: i18n
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-08-20 16:45 UTC by A S Alam
Modified: 2013-07-03 01:03 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-20 18:49:58 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
korean Screenshot (4.24 KB, image/png)
2010-08-20 16:45 UTC, A S Alam
no flags Details
timezone selection in zh_CN - broken rendering (3.52 KB, image/png)
2010-08-20 16:45 UTC, A S Alam
no flags Details

Description A S Alam 2010-08-20 16:45:12 UTC
Created attachment 439988 [details]
korean Screenshot

Description of problem: 
During Korean (ko_KR) GUI installation, when press Alt+Ctrl+Backspace in Virtual Machine, fallback to TUI mode, where Error message appears as "Language Unavailable", while OK (not sure whether it ok button) button's has Black box. After pressing that, whole tui starts actually in selected language (here ko_KR), but for CJKI languages, it should be en_US after "Language Unavailable" message.

Version-Release number of selected component (if applicable):
anaconda-13.21.78-1.el6.x86_64.rpm

How reproducible:
100%

Steps to Reproduce:
1. run GUI installation in Korean (Japanese,Chinese, Indic locale)
2. after package selection, Press Alt+Ctrl+Backspace
3. Language Unavailable message appears
  
Actual results:
installation continue in selected locale

Expected results:
installation should continue in en_US locale

Additional info:
Language List
ko_KR
ja_JP
zh_TW
zh_CN
*_IN

Comment 1 A S Alam 2010-08-20 16:45:51 UTC
Created attachment 439989 [details]
timezone selection in zh_CN - broken rendering

Comment 3 Chris Lumens 2010-08-20 18:17:59 UTC
Why are you pressing ctrl-alt-backspace?  That doesn't make any sense to me.

If you do a plain text install by adding the text cmdline parameter, do you see the same behavior?

Comment 4 A S Alam 2010-08-20 18:37:11 UTC
(In reply to comment #3)
> Why are you pressing ctrl-alt-backspace?  That doesn't make any sense to me.
> 

surely it did make any sense,it was just accident.
 
> If you do a plain text install by adding the text cmdline parameter, do you see
> the same behavior?

No, There is no problem. it is working.

Comment 5 Chris Lumens 2010-08-20 18:49:58 UTC
I advise against killing X mid-install, as anaconda is not at all set up to know how to recover from that situation.


Note You need to log in before you can comment on or make changes to this bug.