Bug 6260 - Installer fails to use more than 5 SCSI disks
Installer fails to use more than 5 SCSI disks
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
6.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-10-22 14:59 EDT by Jakob Xstergaard
Modified: 2015-01-07 18:39 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-09-19 18:59:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jakob Xstergaard 1999-10-22 14:59:52 EDT
When installing RH6.1, the installer recognizes the AIC7xxx
controller and the two NCR53c8xx controllers. One drive is
on the AIC controller, and each of the NCR controllers have
three disks attached.

Just before disk-druid starts, it complains that it cannot
read the partition tables from sdf and sdg.

If I try a ``cat /tmp/sdf'' I also get the ``device not
configured'' error. This seems to me as a kernel problem.

The 2.2.3 kernel (which the machine is currently running on
a heavily upgraded RH5.1) has no problem in using all the
disks. I guess the RH kernel patches breaks something, or ?
Comment 1 Jay Turner 1999-12-01 15:14:59 EST
This issue has been assigned to a developer for further action.
Comment 2 Jay Turner 1999-12-06 10:39:59 EST
Have you tried initializing the drives which Disk Druid says it cannot read the
partition table for.  It Disk Druid cannot read the partition tables, then those
drives will not show up in the list of available drives.  In addition, you will
not be able to cat the devices, as the installer cannot recognize them.
Comment 3 jvv 1999-12-09 18:50:59 EST
I just ran into what seems like the same problem with both rh6.0 and rh6.1. I
have a system with an onboard two-channel ncr53c8xx controller, and I've added
two 2940u2w's. In my case, there's no problem during installation. Disk Druid
sees all of the disks (eight at the moment - one on an onboard channel, four on
one 2940u2w, and three on the other 2940u2w). Once the system is up and running,
however, no disk device beyond sde works. However, the system is aware of all of
the disks on some level: everything in /proc/scsi is correct, and has info about
all disks.

Anyway, I just tried bringing up the system without loading the ncr53c8xx
module, and I can now see all seven of the disks on the Adaptec controllers. So,
it looks like the aic7xxx and ncr53c8xx modules don't get along very well. I
hope this helps. Let me know if you need more info.
Comment 4 Jakob Xstergaard 1999-12-10 02:20:59 EST
I ended up installing the system with  rpm --root ..., since the RAID was
already created on the old configuration.

All disks had partition tables, so it's strange that the kernel shouldn't be
able to read them. And even if it was so, why couldn't I cat /dev/sdf ? That's
not a partition, it's an entire disk without partitions.  The disks were
recognized by the kernel (seen in dmesg) but they just didn't work for some
strange reason.

The system is now running 2.2.13ac2, in a pretty standard configuration with the
AIC and NCR controllers getting along just fine.
Comment 5 Jay Turner 2000-02-08 13:48:59 EST
Added this to a list of things to be aware of with future releases.
Comment 6 Michael Fulbright 2000-09-19 18:59:22 EDT
Is this still a problem with Red Hat 6.2 - please reopen if so.

Note You need to log in before you can comment on or make changes to this bug.